WebHelp Responsive: Generated text strings not found when published using build server

dex.cook
Posts: 7

WebHelp Responsive: Generated text strings not found when published using build server

Tue Jan 03, 2017 10:01 pm

I am using TeamCity with DITA-OT 1.8.5 and the latest WebHelp plugin to automate my WebHelp builds. The output is mostly correct, but generated text for several labels on the HTML pages is not being found. The following warnings are generated during the process.reviews ANT target for each DITA topics referenced in my map, so each HTML output file has the same problem.

Code: Select all

       [xslt] Processing F:\temp\common\reference\reference_ForMoreInformation.dita to F:\target\help\common\reference\reference_ForMoreInformation.html
[INFO] [xslt] Loading stylesheet C:\DITA\DITA-OT1.8.5\plugins\com.oxygenxml.webhelp\xsl\dita\responsive\dita2webhelp.xsl
[INFO] [xslt] [DOTX052W][WARN]: No string named 'printThisPage' was found when creating generated text; using the value 'printThisPage' in your output file.  The location of this problem was at (File = F:\source\common\reference\reference_ForMoreInformation.dita, Element = reference:1;7:46)
[INFO] [xslt] [DOTX052W][WARN]: No string named 'linkToThis' was found when creating generated text; using the value 'linkToThis' in your output file.  The location of this problem was at (File = F:\source\common\reference\reference_ForMoreInformation.dita, Element = reference:1;7:46)
[INFO] [xslt] [DOTX052W][WARN]: No string named 'Output generated by' was found when creating generated text; using the value 'Output generated by' in your output file.  The location of this problem was at (File = F:\source\common\reference\reference_ForMoreInformation.dita, Element = reference:1;7:46)
[INFO] [xslt] [DOTX052W][WARN]: No string named 'webhelp.search' was found when creating generated text; using the value 'webhelp.search' in your output file.  The location of this problem was at (File = F:\source\common\reference\reference_ForMoreInformation.dita, Element = reference:1;7:46)
[INFO] [xslt] [DOTX052W][WARN]: No string named 'label.home' was found when creating generated text; using the value 'label.home' in your output file.  The location of this problem was at (File = F:\source\common\reference\reference_ForMoreInformation.dita, Element = reference:1;7:46)
[INFO] [xslt] [DOTX052W][WARN]: No string named 'printThisPage' was found when creating generated text; using the value 'printThisPage' in your output file.  The location of this problem was at (File = F:\source\common\reference\reference_ForMoreInformation.dita, Element = reference:1;7:46)


I am not sure why the process.reviews step is occurring since this appears to be controlled by the "webhelp.show.changes.and.comments" argument. I am have not set that argument for any value, and the documentation says it should default to not processing tracked changes and comment. Any idea why this would happen in one case and not the other?
alin
Site Admin
Posts: 120

Re: WebHelp Responsive: Generated text strings not found when published using build server

Wed Jan 04, 2017 6:38 pm

Hello,

We have managed to reproduce the issue regarding the missing labels. We are currently investigating the problem and we will notify you when we have a solution for it. It seems the problem occurs when the WebHelp Plugin is run from the command line. If the transformation is performed from oXygen the labels are generated as expected.

The "process.reviews" appears in the ANT log because it is called by another target (via antcall), but it does not get executed. The tasks that are listed after it belong to the calling target. None of the tasks from the "process.reviews" target are executed.

Regards,
Alin
Alin Balasa
Software Developer
<oXygen/> XML Editor
http://www.oxygenxml.com
gbmoore
Posts: 6

Re: WebHelp Responsive: Generated text strings not found when published using build server

Fri Feb 10, 2017 3:58 am

We are seeing the same error messages in our command line build log files, but our issue relates to linktext and navtitle. We are implementing topicrefs as keys and have a cross-book key reference file that contains the topicref keys, listed as a mapref in the root map. These keys are then used as xrefs in topics. We are getting the same error messages as listed above when we run webhelp responsive from the command line, and the topicrefs simply appear in the html as

Code: Select all

<span class="xref"></span>


However, if I run the same build from oXygen editor, the xrefs do display as URLs. So the keys that are used as xrefs in topics should generate at least with URLs when running from a command line, but they do not. They do in the vanilla toolkit plugins, and all of our customized pdf and html plugins.

There is also a secondary issue: we really want the navtitle property to display instead of a URL, as it is much more user friendly and has more meaning inline with other context. We have a customized topicpull plugin that moves the navtitle value to MERGED.xml, which subsequently gets moved to output html and PDF. This works perfectly for the vanilla toolkit plugins, and our customized plugins. However, the webhelp responsive plugin does not pick up the navtitle or linktext from MERGED.xml. We will need additional assistance to get this feature working. I am glad to send full samples of our files for testing by your team.

Here is a sample of inside the cross-reference key file

Code: Select all

<keydef keys="select_options_on_the_outreach_tab"
              format="html"
              scope="external"
              href="http://www.mydomain.com/pls/topic/lookup?ctx=cloud&amp;id=DOCIDar1130818">
         <topicmeta>
            <navtitle>Select Outreach permissions</navtitle>
         </topicmeta>
      </keydef>
      <keydef keys="select_options_on_the_service_tab"
              format="html"
              scope="external"
              href="http://www.mydomain.com/pls/topic/lookup?ctx=cloud&amp;id=DOCIDar1189594">
         <topicmeta>
            <navtitle>Select Service permissions</navtitle>
         </topicmeta>
      </keydef>


And here is how the cross reference key file is referenced in the map (in bold below)

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!--Arbortext, Inc., 1988-2012, v.4002-->
<!DOCTYPE bookmap PUBLIC "-//OASIS//DTD DITA BookMap//EN"
 "bookmap.dtd">
<bookmap xml:lang="en">
<booktitle>
<mainbooktitle>My Guide</mainbooktitle>
</booktitle>
<bookmeta>
<prodinfo>
<prodname>My Product</prodname>
<vrmlist><vrm version="February 2017"/></vrmlist>
<prognum></prognum>
<brand>brand</brand>
<series>series</series>
</prodinfo>
</bookmeta>
<frontmatter>
<keydef keys="product">
<!--Enter value for Product-->
<topicmeta><keywords><keyword>My Product</keyword></keywords>
</topicmeta>
</keydef>
<keydef keys="deliverable">
<!--Enter value for deliverable - same as <mainbooktitle>-->
<topicmeta><keywords><keyword>My Guide</keyword>
</keywords></topicmeta>
</keydef>
<keydef keys="rev">
<!--Enter value for Revision-->
<topicmeta><keywords><keyword>February 2017</keyword></keywords>
</topicmeta>
</keydef>
<keydef keys="partnum">
<!--Enter value for Part Number-->
<topicmeta><keywords><keyword>I01144</keyword></keywords></topicmeta>
</keydef>
<keydef keys="author">
<!--Enter Author name - optional-->
<topicmeta><keywords><keyword>Information Development
Team</keyword></keywords></topicmeta>
</keydef>
<keydef keys="copyrightdate">
<!--Enter value for Copyright Date-->
<topicmeta><keywords><keyword>2017</keyword></keywords></topicmeta>
</keydef>
<keydef keys="docid">
<topicmeta><keywords><keyword>ABCDE</keyword></keywords></topicmeta>
</keydef>
<mapref href="../ProductKeys.ditamap"
navtitle="Product Abbreviations Keyword Map"></mapref>
[b]<mapref href="sample_cross-book-html-keydefs.ditamap"
processing-role="resource-only"></mapref>[/b]
<booklists>
<toc/></booklists>
</frontmatter>
<chapter format="ditamap" href="keystest.ditamap"
navtitle="My Guide"></chapter>
</bookmap>


Sample xref using a keyref

Code: Select all

See <xref keyref="select_options_on_the_service_tab"
></xref> for more information.


Looking forward to seeing an update on where this issue is within oXygen and assistance with the secondary issue. Thank you.
Radu
Posts: 5386

Re: WebHelp Responsive: Generated text strings not found when published using build server

Fri Feb 10, 2017 3:04 pm

Hi,

The warnings that this thread discusses and that you also obtain are not related to your keyref problem.
If you come up with a sample DITA Map project to exemplify you can zip and send it to us via email (support@oxygenxml.com). Please include also the Oxygen version number and the used DITA OT number. And also if possible the entire ANT console output that you receive on your side when running the publishing.

About this requests:
There is also a secondary issue: we really want the navtitle property to display instead of a URL, as it is much more user friendly and has more meaning inline with other context. We have a customized topicpull plugin that moves the navtitle value to MERGED.xml, which subsequently gets moved to output html and PDF. This works perfectly for the vanilla toolkit plugins, and our customized plugins. However, the webhelp responsive plugin does not pick up the navtitle or linktext from MERGED.xml.


Your PDF customization is not related in any way to the HTML output customization. The HTML-based outputs do not generate a MERGED.xml, they generate individual HTML documents for each topic. Once we look into the samples maybe we'll have some ideas to advice you on this aspect.


Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
gbmoore
Posts: 6

Re: WebHelp Responsive: Generated text strings not found when published using build server

Wed Feb 15, 2017 1:42 am

Hi Radu,
We decided to test our keys implementation with webhelp responsive instead of webhelp classic, and it resolved both issues cited above.

Thank you for your response and I'm glad to report our success with whr.

Gina
dex.cook
Posts: 7

Re: WebHelp Responsive: Generated text strings not found when published using build server

Tue Mar 14, 2017 3:27 pm

Is there any update on a fix for the original issue? I want to put the WebHelp system into production use, but I can't until this issue is resolved.
radu_pisoi
Posts: 319
Location: Craiova

Re: WebHelp Responsive: Generated text strings not found when published using build server

Thu Mar 16, 2017 4:33 pm

Hi,

We managed to find a solution for the initial problem. The next oXygen version that will be available in a couple of weeks will contain a fix for it.
Radu Pisoi
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
sorin_carbunaru
Site Admin
Posts: 140

Re: WebHelp Responsive: Generated text strings not found when published using build server

Fri Apr 07, 2017 1:43 pm

Hello,

I just wanted to let you know that oXygen 19.0 is now available, and in this version the WebHelp internationalization support properly works with DITA-OT 1.8.x.

Best wishes,
Sorin Carbunaru
oXygen XML
dex.cook
Posts: 7

Re: WebHelp Responsive: Generated text strings not found when published using build server

Fri Apr 07, 2017 3:15 pm

Tested this today and it works as expected. Thanks for getting the issue fixed.

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: Google [Bot] and 2 guests