XInclude appears to break tag insight

<oXygen/> general issues.
ben
Posts: 2

XInclude appears to break tag insight

Wed Sep 28, 2005 1:56 am

Hi,

With oxygen 6.2 (OSX 10.4.2) tag insight does not appear to work anymore when I use XInclude. Please see the following XML:

Code: Select all

<piperdb xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="piperdb-test.xsd"
xmlns:xi="http://www.w3.org/2001/XInclude">
   
  <!--<xi:include href="countriesdb.xml"/>-->
  <countriesdb>
    <country id="EC" name="Ecuador"/>
  </countriesdb>
   
  <species name="achupallasense">
    <authors>
      <author>Yunck.</author>
    </authors>
  </species>

</piperdb>


This way, when I want to add a new species "<species" correctly shows up in the insight popup. However, If I delete the <countriesdb> ...</countriesdb> stuff and instead include it by uncommenting <xi:include... the only thing that shows up in the popup is

/piperdb>
!-- -->
![CDATA[]]>

XInclude support is enabled in preferences and pretty much all tag insight features as well. What's going on here?

Thanks for your help,

Ben

BTW: Great app! I'm on a trial license at the moment, but will definitely buy one, if I get the insight stuff straight again ;-)
george
Site Admin
Posts: 2100

Wed Sep 28, 2005 10:40 am

Hi Ben,

Oxygen does not currently look inside the included document when it offers content completion proposals and the proposals are context sensitive and xi:include does not appear in the schema so the set of proposals after the xi:include is empty.
A possible solution will be to change the schema to allow xi:include in a choice model with the element you want to place inside the included document, countriesdb in your case.
Example:
<xs:element ref="countriesdb" ...
should be changed to

<xs:choice ...>
<xs:element ref="countriesdb">
<xs:element ref="xi:include">
</xs:choice>

Note that if you have a public location of the schema you can change the schema only locally and then map the public location to the local changed copy through an XML Catalog.
I also added a bugzilla entry with this as a feature request and we will handle such cases in future oXygen releases without the need to change the schema.

Best Regards,
George
ben
Posts: 2

Wed Sep 28, 2005 12:26 pm

Hi George,

It works like you have said. I had to import the namespace of xinclude as well.
Now completions are back and I am happy again.

Thanks very much,

Ben

Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 2 guests