Using subject scheme in keyref

Pascale
Posts: 40
Joined: Wed Jan 29, 2014 4:30 pm

Using subject scheme in keyref

Post by Pascale » Fri Apr 03, 2015 2:46 pm

Hi,

I have defined a subject scheme map where I define keyword elements.

Code: Select all

<subjectScheme>
<subjectHead>
<subjectHeadMeta><navtitle>Platform classification</navtitle></subjectHeadMeta>
</subjectHead>
<hasInstance>
<subjectdef keys="platform">
<subjectdef keys="defaultPlatform"><topicmeta><keywords><keyword>MS Windows</keyword></keywords></topicmeta></subjectdef>
<subjectdef keys="Unix"><topicmeta><keywords><keyword>Unix</keyword></keywords></topicmeta>
<subjectdef keys="AIX"><topicmeta><keywords><keyword>AIX</keyword></keywords></topicmeta></subjectdef>
<subjectdef keys="Linux"><topicmeta><keywords><keyword>Linux</keyword></keywords></topicmeta></subjectdef>
<subjectdef keys="Solaris"><topicmeta><keywords><keyword>Solaris</keyword></keywords></topicmeta></subjectdef>
</subjectdef>
<subjectdef keys="Windows"><topicmeta><keywords><keyword>MS Windows</keyword></keywords></topicmeta>
<subjectdef keys="WindowsXP"><topicmeta><keywords><keyword>MS Windows XP</keyword></keywords></topicmeta>
<subjectdef keys="WindowsXPPro"><topicmeta><keywords><keyword>MS Windows XP Pro</keyword></keywords></topicmeta></subjectdef>
</subjectdef>
<subjectdef keys="Windows7"><topicmeta><keywords><keyword>MS Windows 7</keyword></keywords></topicmeta></subjectdef>
<subjectdef keys="Windows8"><topicmeta><keywords><keyword>MS Windows 8</keyword></keywords></topicmeta></subjectdef>
<subjectdef keys="WindowsServer2008R2"><topicmeta><keywords><keyword>MS Windows 2008 R2</keyword></keywords></topicmeta></subjectdef>
</subjectdef>
</subjectdef>
</hasInstance>
</subjectScheme>
In my root map, I have included that subject scheme and have defined 2 enumerationdef elements, one to use the subject scheme with the platform attribute, the second to use the subject scheme with the keyref attribute of the keyword element.

Code: Select all


    <enumerationdef>
<attributedef name="platform"/>
<subjectdef keyref="platform"/>
</enumerationdef>
<enumerationdef>
<elementdef name="keyword"/>
<attributedef name="keyref"/>
<subjectdef keyref="platform"/>
<defaultSubject keyref="defaultPlatform"/>
</enumerationdef>
When I enter manually a key in the keyword/keyref, it is correctly displayed in Author mode, and correctly published in PDF using DITA OT.
However, when I want to use the menu option "DITA > Link > Key reference" the dialog box remains empty.
Also, in the attribute view, when I click on the platform attribute I get a drop-down list with all keys defined in my subject scheme, but when I clcik on the keyref attribute that does not happens.

Can you please explain what I am doing wrong? Or is it a bug?

Radu
Posts: 6453
Joined: Fri Jul 09, 2004 5:18 pm

Re: Using subject scheme in keyref

Post by Radu » Fri Apr 03, 2015 3:18 pm

Hi Pascale,

This is related to your previous post here:

http://www.oxygenxml.com/forum/post3318 ... ord#p33183

Right now the Oxygen interface explicitly filters out keys defined on <subjectdef> elements in the dialogs which are used to create key references.
Your use case of defining keyword metadata directly in a Subject Scheme map is not a very common one but nonetheless I think it is a valid usage so we'll try to also accommodate it.
So hopefully we'll have a fix for this in Oxygen 17 (April-May this year).

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Pascale
Posts: 40
Joined: Wed Jan 29, 2014 4:30 pm

Re: Using subject scheme in keyref

Post by Pascale » Fri Apr 03, 2015 5:53 pm

Hi Radu,

you are right, this was somewhat related to the post of my colleague Xavier. However here we were only trying to use the out-of-the-box features of the AUthor mode in Oxygen, not the API.

I am glad that you plan to provide a fix in the comming weeks, and will be happy to test it and provide feedback if you want.

Have a nice Easter week-end, kind regards,
Pascale

Radu
Posts: 6453
Joined: Fri Jul 09, 2004 5:18 pm

Re: Using subject scheme in keyref

Post by Radu » Mon May 18, 2015 3:31 pm

Hi Pascale,

This issue should be fixed in the newest Oxygen 17.0 available on our site.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply