fontInherit in oxy_textfield doesn't work?!

Post here questions and problems related to oXygen frameworks/document types.
stdu
Posts: 81

fontInherit in oxy_textfield doesn't work?!

Tue Sep 03, 2013 12:26 pm

In Oxygen XML Author 14.2 I would like to use a special font for an oxy_textfield, but it seems, that the property "fontInherit" doesn't work. Or have I made a mistake in my CSS?

Code: Select all

msIdentifier repository {
      font-family: DejaVuSans;
   content:
      oxy_label(text,"Bibliothek*:",width,5em)
      oxy_textfield(edit,"#text",columns,40,fontInherit,true);
}


The Label is correctly displayed in DejaVuSans, the content of oxy_textfield not.
alex_jitianu
Posts: 653

Re: fontInherit in oxy_textfield doesn't work?!

Tue Sep 03, 2013 2:30 pm

Hello,

The CSS looks correct. From what I've tested I've managed to reproduce this behavior I dynamically load the DejaVuSans font using @font-face rule? I've added an issue for the dynamically loaded fonts to be used by form controls too. Please let me know if this is indeed your situation too or we should dig deeper for the cause.

Best regards,
Alex
stdu
Posts: 81

Re: fontInherit in oxy_textfield doesn't work?!

Wed Sep 04, 2013 12:16 pm

Hi Alex,

thanks for your reply and yes, I load the font via @font-face!

By the way: it seems, that Oxygen XML 14.2 transform the sourcepath (or just the filename?) of a font in @font-face always in lowercase.

So if you have

Code: Select all

@font-face {
    font-family: "Junicode";
    src:url("http://www.yourdomain.com/path/JuniCode.ttf");
    font-style: normal;
}


Oxygen XML tries to load http://www.yourdomain.com/junicode.ttf, what gives me an "Not found" error in Oxygen XML. Renaming the font on the server in lowecase letters fix it. But probably this behaviour isn't intended?

Best regards,
Stefan
alex_jitianu
Posts: 653

Re: fontInherit in oxy_textfield doesn't work?!

Wed Sep 04, 2013 2:04 pm

Hi Stefan,

Thank you for reporting this behavior which is indeed not an intended one... I've added an issue to fix it for the next version of Oxygen.

Best regards,
Alex
Radu
Posts: 5987

Re: fontInherit in oxy_textfield doesn't work?!

Wed Oct 23, 2013 8:51 am

Hi Stefan,

Just to update this thread, a fix for this issue should be available in 15.1.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Return to “SDK-API, Frameworks - Document Types”

Who is online

Users browsing this forum: No registered users and 0 guests