Search found 2736 matches

by adrian
Wed Mar 24, 2010 5:21 pm
Forum: Common Problems
Topic: ZendStudio crashes after upgrading to 11.2
Replies: 20
Views: 9621

Re: ZendStudio crashes after upgrading to 11.2

The build that fixes these problems is now available( 2010032411 ): Download from: http://www.oxygenxml.com/download_oxygenxml_editor.html Install in Eclipse from: http://www.oxygenxml.com/InstData/Editor/Eclipse/site.xml Or simply Check for Updates from Eclipse/Zend Studio if you have installed Oxy...
by adrian
Wed Mar 24, 2010 5:19 pm
Forum: Common Problems
Topic: "File Icons Based on Content Analysis" hangs Eclipse/oXygen
Replies: 2
Views: 2729

Re: "File Icons Based on Content Analysis" hangs Eclipse/oXygen

The build that fixes these problems is now available( 2010032411 ): Download from: http://www.oxygenxml.com/download_oxygenxml_editor.html Install in Eclipse from: http://www.oxygenxml.com/InstData/Editor/Eclipse/site.xml Or simply Check for Updates from Eclipse/Zend Studio if you have installed Oxy...
by adrian
Wed Mar 24, 2010 4:16 pm
Forum: Common Problems
Topic: "File Icons Based on Content Analysis" hangs Eclipse/oXygen
Replies: 2
Views: 2729

Re: "File Icons Based on Content Analysis" hangs Eclipse/oXygen

Hello, Like I mentioned on the other topic( ZendStudio crashes after upgrading to 11.2 ) this was the behaviour we were encountering when testing with ZendStudio. When the plugin was initialized it would freeze ZendStudio rather than crashing it. A new Oxygen build will be available by the end of th...
by adrian
Tue Mar 23, 2010 5:15 pm
Forum: Common Problems
Topic: ZendStudio crashes after upgrading to 11.2
Replies: 20
Views: 9621

Re: ZendStudio crashes after upgrading to 11.2

Right now the best workaround is the one you have found. Copy /usr/lib64/libhunspell-1.2.so.0 to the plugins/com.oxygenxml.editor_11.2.0.v2010032314/lib/hunspell directory from the ZendStudio installation directory and rename it to libhunspell-linux-x86-64.so. We are working on building a statically...
by adrian
Tue Mar 23, 2010 4:41 pm
Forum: Common Problems
Topic: ZendStudio crashes after upgrading to 11.2
Replies: 20
Views: 9621

Re: ZendStudio crashes after upgrading to 11.2

We managed to reproduce the hunspell crash in both Ubuntu 9.10 and openSUSE 11.2 64bit.

Regards,
Adrian
by adrian
Tue Mar 23, 2010 4:24 pm
Forum: Feature Request
Topic: Eclipse update site should include "older" versions
Replies: 3
Views: 1939

Re: Eclipse update site should include "older" versions

Hello,

That's what we've actually been considering, to simply have a separate update site which provides all the versions we have available.

Regards,
Adrian
by adrian
Tue Mar 23, 2010 3:28 pm
Forum: Common Problems
Topic: ZendStudio crashes after upgrading to 11.2
Replies: 20
Views: 9621

Re: ZendStudio crashes after upgrading to 11.2

Hello, We are still investigating this. So far we have only managed to obtain a dead lock(ZendStudio freezes) when the Oxygen plugin is initialized. But no crash(segmentation fault). The strange thing is that even this behaviour seems to only happen in Ubuntu 9.10 64bit. In Ubuntu 8.04 64bit everyth...
by adrian
Tue Mar 23, 2010 12:44 pm
Forum: Other Issues
Topic: Integrating Ant into standalone oXygen
Replies: 8
Views: 5460

Re: Integrating Ant into standalone oXygen

Hello, I know this is an old thread but since it has no resolution I think I'd better clarify some things. When the Preferences dialog is too large does not fit the screen the option panes are displayed with scroll bars. This is a fallback for low resolutions(<1024x768) but it is sometimes triggered...
by adrian
Mon Mar 22, 2010 5:04 pm
Forum: Common Problems
Topic: Unable to start plugin using MyEclipse 8.0
Replies: 7
Views: 3597

Re: Unable to start plugin using MyEclipse 8.0

Hello,

The latest build(2010031913) should resolve the problems in MyEclipse:
http://www.oxygenxml.com/download_oxygenxml_editor.html

Regards,
Adrian
by adrian
Mon Mar 22, 2010 3:46 pm
Forum: Feature Request
Topic: Eclipse update site should include "older" versions
Replies: 3
Views: 1939

Re: Eclipse update site should include "older" versions

Hello, Right now we only keep public the latest minor version for each major version(11.2, 10.3, 9.3, etc) and they are also kept on separate update sites. I'm guessing you noticed that. We'll consider bringing them all together on a common update site. But I believe the choice to separate them has ...
by adrian
Mon Mar 22, 2010 12:13 pm
Forum: XSLT and FOP
Topic: Output Multiple PDF files
Replies: 2
Views: 1476

Re: Output Multiple PDF files

Hi, I spoke too soon. You can actually automate the whole thing and do the same step by step transformations in XProc. Oxygen provides a few simple XProc samples: in <sampleProject>/xproc You can read more about XProc here: http://xproc.org/ http://www.ibm.com/developerworks/library/x-xproc/ http://...
by adrian
Mon Mar 22, 2010 11:54 am
Forum: XSLT and FOP
Topic: Output Multiple PDF files
Replies: 2
Views: 1476

Re: Output Multiple PDF files

Hello, I believe you can only do this in Oxygen in two steps. You already made the first step 1 xml => multiple fo. To make this easier you should output all the FOs in a separate folder(output). The second step is a bit manual. In the Project view of Oxygen link(to external folder) the output folde...
by adrian
Mon Mar 22, 2010 10:30 am
Forum: Feature Request
Topic: Import/export individual transformation scenario
Replies: 5
Views: 3246

Re: Import/export individual transformation scenario

Hello,

I have added a feature request for this to our issue tracking tool and it will be implemented in a future version.

Regards,
Adrian
by adrian
Fri Mar 19, 2010 4:38 pm
Forum: Other Issues
Topic: oxygen 11.2 , framework configuration for xpath not working
Replies: 2
Views: 1302

Re: oxygen 11.2 , framework configuration for xpath not working

Hello,

I think what you're looking for is:

Code: Select all

self::article-id[not(starts-with(text(),'R'))]
This should only execute if the current node is article-id and its next node does not start with 'R'(capital R because starts-with is case sensitive).

Let me know if this works.

Regards,
Adrian
by adrian
Fri Mar 19, 2010 3:15 pm
Forum: Feature Request
Topic: Please Confirm The Latest Current Version
Replies: 1
Views: 1209

Re: Please Confirm The Latest Current Version

Hello,

Apologies for the mix-up, we will correct our site immediately.

The latest build IDs at this time(March 19th) are:
- for Oxygen XML Editor - 2010031814.
- for Oxygen XML Author - 2010031815.

Regards,
Adrian
by adrian
Thu Mar 18, 2010 6:28 pm
Forum: Common Problems
Topic: 11 seems to work, 11.2 quits shortly after starting
Replies: 3
Views: 1422

Re: 11 seems to work, 11.2 quits shortly after starting

Hello,

If possible, please send us the full crash report to support@oxygenxml.com so we can analyse it.

The solutions from "Fatal error code" were for a StackOverflow that occured at startup and it was caused by some large RelaxNG schema.
I don't think your problem is related.

Regards,
Adrian
by adrian
Thu Mar 18, 2010 12:42 pm
Forum: Common Problems
Topic: Unable to start plugin using MyEclipse 8.0
Replies: 7
Views: 3597

Re: Unable to start plugin using MyEclipse 8.0

I have split the topic. You can find the other messages related to the ZendStudio crash in:
ZendStudio crashes after upgrading to 11.2

Regards,
Adrian
by adrian
Thu Mar 18, 2010 12:36 pm
Forum: Common Problems
Topic: Unable to start plugin using MyEclipse 8.0
Replies: 7
Views: 3597

Re: Unable to start plugin using MyEclipse 8.0

Hello, @ewinston : A quick workaround for your problem is to delete the folder usageData from the com.oxygenxml options directory which depending on the operating system is located in: Windows XP - [user-home-folder]/Application Data/com.oxygenxml Windows Vista/7 - [user-home-folder]/AppData/Roaming...
by adrian
Thu Mar 18, 2010 11:42 am
Forum: XSLT and FOP
Topic: Saxon SQL Extension
Replies: 32
Views: 14364

Re: Saxon SQL Extension

Hello, I'm sorry for the late reply. Found the way to make it work with Saxon-PE 9.2: Create a configuration file, saxonConfig.xml , with this content: <?xml version="1.0" encoding="UTF-8"?> <configuration xmlns="http://saxon.sf.net/ns/configuration" edition="PE"> <global allowExternalFunctions="tru...
by adrian
Wed Mar 17, 2010 6:14 pm
Forum: XSLT and FOP
Topic: xsd or DTD validation fro for FOP 0.93
Replies: 4
Views: 2894

Re: xsd or DTD validation fro for FOP 0.93

Hello, I don't think they changed: <fo:root xmlns:fo="http://www.w3.org/1999/XSL/Format" xmlns:fox="http://xmlgraphics.apache.org/fop/extensions"> http://xmlgraphics.apache.org/fop/0.95/extensions.html But I see that you have there a lot of other namespaces, not sure about these... Regards, Adrian
by adrian
Wed Mar 17, 2010 4:02 pm
Forum: Common Problems
Topic: Unable to start plugin using MyEclipse 8.0
Replies: 7
Views: 3597

Re: Unable to start plugin using MyEclipse 8.0

Hello,

Thank you for reporting the problem.
We are investigating it and we will provide a fix as soon as possible.

Regards,
Adrian
by adrian
Wed Mar 17, 2010 1:25 pm
Forum: Common Problems
Topic: Could not open/create prefs root node
Replies: 11
Views: 8822

Re: Could not open/create prefs root node

Hello,

It hasn't been resolved in 11.2. I'm afraid it's the unknown future for this one.

Regards,
Adrian
by adrian
Tue Mar 16, 2010 8:02 pm
Forum: Common Problems
Topic: Author mode - inserting an attribute with & character
Replies: 2
Views: 2027

Re: Author mode - inserting an attribute with & character

Hello,

Thank you for reporting this problem.
I have added it to our bug tracking tool and we will resolve it in a future version.
The problem is that the table remains in editing mode even after selecting another element, that should not happen.

Regards,
Adrian
by adrian
Tue Mar 16, 2010 7:17 pm
Forum: XML Schemas
Topic: Conditional Type Assignment (CTA) ??
Replies: 1
Views: 2038

Re: Conditional Type Assignment (CTA) ??

Hello, Apologies for the very late reply. After configuring the Saxon-EE validation to be 1.1 compliant you will have to create a custom validation scenario. Document -> Validate -> Configure Validation Scenario , select Use custom validation scenario , New , and give it a proper name, Add a new val...
by adrian
Tue Mar 16, 2010 5:24 pm
Forum: Feature Request
Topic: Add support for the XML database "Qizx"
Replies: 3
Views: 2292

Re: Add support for the XML database "Qizx"

Hello,

Right now we don't have plans to support Qizx but we will consider adding support for it in the future. We will let you know when this happens.

Regards,
Adrian
by adrian
Tue Mar 16, 2010 3:09 pm
Forum: XSLT and FOP
Topic: Saxon SQL Extension
Replies: 32
Views: 14364

Re: Saxon SQL Extension

Hello, Oxygen 11.x bundles Saxon-HE/PE/EE 9.2. So first you will need the saxon9-sql.jar from Saxon-EE 9.2(same place http://saxon.sourceforge.net/). The second problem is extensions(including SQL) are no longer supported in Saxon-HE(the equivalent of Saxon-B), so you have to use Saxon-PE or EE as t...
by adrian
Tue Mar 16, 2010 2:03 pm
Forum: Common Problems
Topic: '#' instead of non-ascii character in PDF
Replies: 5
Views: 2144

Re: '#' instead of non-ascii character in PDF

Hello, I'm sorry, there are indeed a few mistakes in the scripts(an extra quote and a line broken in two). To make things simple: For Linux/Mac create ttfConvert.sh : #!/bin/sh java -cp lib/fop.jar:lib/avalon-framework-4.2.0.jar:lib/xercesImpl.jar org.apache.fop.fonts.apps.TTFReader "$@" For Windows...
by adrian
Tue Mar 16, 2010 1:30 pm
Forum: Other Issues
Topic: Formatting/ident without line-breaking elements
Replies: 1
Views: 1255

Re: Formatting/ident without line-breaking elements

Hello, Unfortunately it isn't currently possible with the available options to format an element and let it span over a single unbroken line. The only workaround I can suggest is to increase the line width(Options -> Preferences -> Editor -> Format, Line width) to a larger size so that elements woul...
by adrian
Mon Mar 15, 2010 6:44 pm
Forum: Common Problems
Topic: '#' instead of non-ascii character in PDF
Replies: 5
Views: 2144

Re: '#' instead of non-ascii character in PDF

Hello, The problem is that the characters you use aren't supported by the default font used for the PDF. You have to embed in the PDF a font that supports these characters. There is a procedure in the Oxygen User Manual for setting a font for the PDF output generated with Apache FOP transformation: ...
by adrian
Mon Mar 15, 2010 11:37 am
Forum: Feature Request
Topic: 10.3 - Attributes window doesn't show XSD documentation
Replies: 6
Views: 2852

Re: 10.3 - Attributes window doesn't show XSD documentation

Hello,

A RC for 11.2 is up if you're interested. Feedback is welcome.
http://www.oxygenxml.com/pipermail/oxyg ... 03073.html

Regards,
Adrian