Search found 57 matches

by pault
Tue Jul 15, 2014 5:50 pm
Forum: Other Issues
Topic: Add items to outputclass list
Replies: 8
Views: 1734

Re: Add items to outputclass list

Thanks Radu!
by pault
Thu Jul 10, 2014 12:32 am
Forum: Other Issues
Topic: Add items to outputclass list
Replies: 8
Views: 1734

Add items to outputclass list

In the values for the outputclass attribute, there are list of languages for syntax highlighting, like language-java. I would like replace them with our values (as we implemented syntax highlighting awhile back). Additionally, I'd like to add a couple of others for other element types, such as <p> a...
by pault
Thu Jan 16, 2014 9:47 pm
Forum: Other Issues
Topic: Context root links display validation errors
Replies: 1
Views: 493

Context root links display validation errors

To link between documents residing in different ditamaps, we are using URL formats like this: <xref href="/documentation/upgrade/doc/upgrade/ds/upgrdVerSpecif.html" format="html" scope="external">Version specific upgrade instructions</xref> instead of an absolute URL: <...
by pault
Thu Nov 07, 2013 3:51 am
Forum: Other Issues
Topic: Rename Element
Replies: 1
Views: 502

Rename Element

In Oxygen Editor 14 for the Mac in Author mode, in the context menu that appears when right-clicking a tag, showed a "Rename Element" item at the top: Rename Element Edit Attributes Append child Insert Before ... How do you enable this in Oxygen 15? I have looked and looked to no avail. Th...
by pault
Mon Sep 30, 2013 11:34 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Disable chunking in Mobile output
Replies: 3
Views: 735

Re: Disable chunking in Mobile output

Hi Sorin, I think I misspoke about what I wanted. Currently, in our WebHelp implementation, we use the chunk="to-content" attribute quite a bit in our ditamaps. For example: <topicref href="partitionerAbout.dita" keys="architecturePartitionerAbout" chunk="to-conten...
by pault
Fri Sep 20, 2013 7:06 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Disable chunking in Mobile output
Replies: 3
Views: 735

Disable chunking in Mobile output

I really like the Mobile scenario. Unfortunately chunk to-content isn't processed in the Mobile scenario and content is missing. As a workaround, we are using separate ditamaps for mobile output, but it's kind of a pain. Is there away to disable chunking in the mobile processing?

Thanks,

Paul
by pault
Wed Sep 11, 2013 7:22 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Add ditamap title to gen-user-header
Replies: 4
Views: 898

Add ditamap title to gen-user-header

I have created an XSL file that adds a header (gen-user-header) to each page generated by the DITA MAP XHTML scenario. I would like to add the title of the ditamap to this header. It seems like there should be a simple way to do this. How do you do this?

Thanks,

Paul
by pault
Tue Sep 03, 2013 3:30 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Generating HTML5 from DITA
Replies: 1
Views: 1015

Generating HTML5 from DITA

I would like to develop for HTML5 from DITA source. Basically we need two columns with the TOC being in one column and content in the other. What is the best way to go about this with Oxygen 15?

Thanks

Paul
by pault
Wed Aug 21, 2013 6:27 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: URL produced by WebHelp contain two hash tags
Replies: 8
Views: 4359

Re: URL produced by WebHelp contain two hash tags

Hi Sorin, I installed the toc.js file as described, but many URLs still have two hash marks. I also tried running our files with the unmodified DITA Map WebHelp scenario (except for setting clean.output to yes) with the same results. I also checked that the new toc.js file was copied to the output d...
by pault
Tue Aug 13, 2013 3:45 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: URL produced by WebHelp contain two hash tags
Replies: 8
Views: 4359

Re: URL produced by WebHelp contain two hash tags

Hi Sorin, I don't know why I can't repeat what I did on the Oxygen Editor help to get the URL I sent you, but here's an example from our web site. I'll upload the files later today. Go to http://www.datastax.com/documentation/cassandra/1.2/webhelp/index.html and in the content pane, click Virtual no...
by pault
Thu Aug 08, 2013 8:15 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: URL produced by WebHelp contain two hash tags
Replies: 8
Views: 4359

URL produced by WebHelp contain two hash tags

When you generate WebHelp, it produces some URLs containing two hash tags. For example, in the Oxygen Editor docs: http://www.oxygenxml.com/doc/ug-editor/#topics/set-parameter-in-startup-script.html#set-parameter-in-startup-script The problem that we have is that sometimes when you give the URL to a...
by pault
Mon Jul 22, 2013 7:29 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: WebHelp Search does not find any non-letter characters
Replies: 8
Views: 1828

Re: WebHelp Search does not find any non-letter characters

This is also true for parenthesis, such as note().
by pault
Fri Jul 19, 2013 6:03 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin,

Sorry for the delay in responding. I had a product release that took precedence. I've installed Oxygen 15 and redone my customizations and the problems are gone.

Thanks for all your help!

Paul
by pault
Tue Jun 18, 2013 6:36 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin, So some progress. I replaced the files as you directed. We're almost there! * Search now works in Chrome, Safari, Firefox, and IE. * The links in the Related topics problem pages work in Safari, Chrome, and IE but not Firefox in our customization. * The links do not work in the default web...
by pault
Tue Jun 18, 2013 3:15 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin, The link to this archive gives me this error: Not Found The requested URL /forum/files/webhelp-search-fix-Oxygen-14.2.zip was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. I also don't understand wh...
by pault
Tue Jun 18, 2013 7:22 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin, I think you might have missed my previous message, which said that I had inadvertently sent you files with the original nwSearchFnt.js. file instead of the new one. I did sent another set of files with the new nwSearchFnt.js in place, which I uploaded just a few minutes before you posted y...
by pault
Mon Jun 17, 2013 4:21 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin,

I just realized that I sent you the files without the new nwSearchFnt.js file in place. I am uploading them now.

Paul
by pault
Mon Jun 17, 2013 1:45 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin,

I sent the entire source and output.

Thanks for your help.

Paul
by pault
Fri Jun 14, 2013 1:06 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin, I already have set clean output and clean temp, but I manually deleted the output just in case. I am using Mac Lion (10.7.5) by the way, not Windows. The behavior is the same as before. From the files I sent you previously, open Security, select Configuring firewall port access, and select...
by pault
Wed Jun 12, 2013 8:36 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin, I tried it and had one of my coworkers try it and the same problem still exists. In fact, search doesn't work when using the new file. Also I had the same results with both the default WebHelp and our custom scenario. Is there some other configuration change that needs to be made? I tired ...
by pault
Mon Jun 10, 2013 5:59 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin, I sent you the files on the 7th. I noticed that the same kind of thing is happening with the term references, where an xref works but the term ref doesn't: <term keyref="gloss-read-repair">read repair</term> I installed Oxygen 15 and ran the default WebHelp to see if it solved th...
by pault
Fri Jun 07, 2013 6:55 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin,

I have send a truncated sample version that illustrates the problem.

Thanks for your help.

Paul
by pault
Tue Jun 04, 2013 11:15 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Re: Link keyref not working in WebHelp

Hi Sorin,

I installed the maintenance release (2013051016) but the problem still exists. This time I also tested it using a regular link (<link href="../architecture/architecturePlanningEC2_c.dita"/>) and the behavior is the same.

Any other suggestions?

Paul
by pault
Tue May 28, 2013 7:05 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Link keyref not working in WebHelp
Replies: 22
Views: 3436

Link keyref not working in WebHelp

There seems to be a problem with using keyref with the links tag. I have tested this both in my customized WebHelp and the unmodified WebHelp transformation. The problem exists in the non-framed version, but not the framed version. From the same document, this link works: <p><xref keyref="archi...
by pault
Thu Mar 21, 2013 8:15 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Add Logo to WebHelp
Replies: 23
Views: 3911

Re: Add Logo to WebHelp

Thanks Sorin,

It didn't occur to me that this could be solved simply using CSS. One slight correction, the internal frames CSS is [Oxygen-install-dir]\frameworks\dita\DITA-OT\plugins\com.oxygenxml.webhelp\oxygen-webhelp\resources\css\tocWDiv.css
by pault
Thu Mar 21, 2013 1:12 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Add Logo to WebHelp
Replies: 23
Views: 3911

Add Logo to WebHelp

I know how to add a logo to the contents frame using args.hdr or args.hsf in WebHelp, but I don't understand how to add a logo above the Content and Search tabs? Specifically I would like to add a logo to the left of the displayed title (ie, generated by the name of the ditamap) in the top-left corn...

Go to advanced search