Search found 88 matches

by Jamil
Thu Aug 20, 2020 8:50 pm
Forum: Feature Request
Topic: Move oxygen*.vmoptions To Home Directory
Replies: 3
Views: 262

Re: Move oxygen*.vmoptions To Home Directory

If I may install a new version (major or minor) without losing my vmoptions and never have to manually edit anything (that I later forget to do), this will meet my needs.

If I still have to remember to edit files, this will not help me.
by Jamil
Thu Aug 20, 2020 9:24 am
Forum: Feature Request
Topic: Move oxygen*.vmoptions To Home Directory
Replies: 3
Views: 262

Re: Move oxygen*.vmoptions To Home Directory

After thinking about this a little more, there's changes you may make to minimize the amount of work needed to complete my request. I propose the following changes: Keep the existing vmoptions file creation in OxygenXML's installation location as currently. For the latest version, it is called oxyge...
by Jamil
Wed Aug 19, 2020 10:50 pm
Forum: Feature Request
Topic: Move oxygen*.vmoptions To Home Directory
Replies: 3
Views: 262

Move oxygen*.vmoptions To Home Directory

I increase JVM memory to oxygen*.vmoptions only to have it lost when I update to a newer release. Some times I forget to update it again and only learn of insufficient memory when I see an error message. My request is to move this configuration file to the associated users home directory. This way i...
by Jamil
Wed Jul 01, 2020 1:18 am
Forum: XSLT and FOP
Topic: BOM Handling Question
Replies: 4
Views: 442

Re: BOM Handling Question

Thanks, and I was not even aware this attribute existed. This solved the issue.
by Jamil
Mon Jun 29, 2020 9:54 pm
Forum: XSLT and FOP
Topic: BOM Handling Question
Replies: 4
Views: 442

Re: BOM Handling Question

Hi Radu. The issue I face is that the Unicode file is not interpreted correctly resulting in character loss for UTF-8. My XSLT output is text containing UTF-8. There is no indicator for this other than the BOM. Since it is missing, data gets interpreted incorrectly resulting in data loss. For UTF-8,...
by Jamil
Tue Jun 23, 2020 6:28 pm
Forum: XSLT and FOP
Topic: BOM Handling Question
Replies: 4
Views: 442

BOM Handling Question

I am noticing that when I execute an XSLT with encoding set for UTF-8, the BOM is not being created in the output file. I just checked Ecoding under preferences, and UTF-8 BOM handling is set for keep. For a new file, I want the BOM to always be added to the output file. My transformer is set to Sax...
by Jamil
Mon Jun 22, 2020 12:14 am
Forum: Other Issues
Topic: Can I Disable Windows Text Size Zoom
Replies: 4
Views: 381

Re: Can I Disable Windows Text Size Zoom

I just found the option and disabled it under Preferences: Editor, Zoom: Enable mouse-wheel zooming

Thanks for forward thinking and adding this.

My questions have all been answered.
by Jamil
Sun Jun 21, 2020 11:49 pm
Forum: Other Issues
Topic: Can I Disable Windows Text Size Zoom
Replies: 4
Views: 381

Re: Can I Disable Windows Text Size Zoom

It seems that Microsoft introduced this at some point in time as an update to Windows. Every single Windows application on my computer will change font size with CTRL held down while moving the mouse wheel. I can find absolutely no way to disable this behavior in Control Panel settings. I am using a...
by Jamil
Sun Jun 21, 2020 9:26 pm
Forum: Other Issues
Topic: Can I Disable Windows Text Size Zoom
Replies: 4
Views: 381

Re: Can I Disable Windows Text Size Zoom

Reset Global Options restored the default font sizes.

I just need an answer to #1 above.
by Jamil
Sun Jun 21, 2020 9:22 pm
Forum: Other Issues
Topic: Can I Disable Windows Text Size Zoom
Replies: 4
Views: 381

Can I Disable Windows Text Size Zoom

I accidentally held down CTRL while scrolling the mouse wheel. This resulted in the font sizes changing to now be unreadable.

Two questions--

1. Can I disable this? If so, how can I turn this off?

2. How can I restore all font sizes to default?

Thanks.
by Jamil
Sun Jun 16, 2019 4:30 am
Forum: Feature Request
Topic: XML Usage Decreasing JSON Increasing
Replies: 2
Views: 1453

XML Usage Decreasing JSON Increasing

For new feature development, XML is now no longer considered at my location. It is what it is, but this is the reality. I am aware that there are feature requests for JSON improvements. My am requesting that more focus be added to JSON support. I am sure someone has requested a feature to automatica...
by Jamil
Sat Aug 12, 2017 12:03 am
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

Re: NullPointerException During Install

I am now seeing that this issue is resolved with Bitdefender 2018. The issue remains in the 2017 version.
by Jamil
Tue Apr 11, 2017 12:00 pm
Forum: Other Issues
Topic: New Install of 19.0 Enterprise Error
Replies: 6
Views: 2375

Re: New Install of 19.0 Enterprise Error

Thanks for tracking this issue down. I do not remember what I may have done with the project files on my laptop (this is where the warning appeared). However, I generally do not do anything out of the ordinary with the software. With every new install, I arrange the toolbars within the editor a spec...
by Jamil
Sat Apr 08, 2017 9:58 am
Forum: Other Issues
Topic: New Install of 19.0 Enterprise Error
Replies: 6
Views: 2375

Re: New Install of 19.0 Enterprise Error

It happened for every project file that existed on my laptop after the v19 installation. However, it then no longer appeared the next time I opened the same project files. Whatever the issue was, it seems to have gone away. I am not sure if sending the project files that now no longer have the issue...
by Jamil
Fri Apr 07, 2017 8:47 am
Forum: Other Issues
Topic: New Install of 19.0 Enterprise Error
Replies: 6
Views: 2375

New Install of 19.0 Enterprise Error

New install where I selected the option to uninstall version 18.1. This happens during the installation toward the end with the splash screen remaining visible: https://yoqxuw-ch3302.files.1drv.com/y4p45vHb4Etr_zYxZfsl6IwB1BQURevNsy-hhTKFY5QUaARX9XvH9AdmWlhLsNp5nq9O3HX_FncDcKZzindsNQBYSNa3914aq4aqML...
by Jamil
Mon Mar 27, 2017 10:28 am
Forum: XSLT and FOP
Topic: Test whether file exists
Replies: 3
Views: 3038

Re: Test whether file exists

Your use case is not making sense to me. Based on your description, XSLT does not seem appropriate for what you wish to do. Why not test for file existence in Java instead?
by Jamil
Mon Mar 06, 2017 2:50 am
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

Re: NullPointerException During Install

The issue remains unresolved by Bitdefender. Apparently, they are unable to reproduce the install issue. For reasons unknown to me, they are able to install oxygen without Bitdefender causing this issue on their computers. I have simply uninstalled Bitdefender in the meantime.
by Jamil
Fri Oct 28, 2016 4:20 pm
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

Re: NullPointerException During Install

This is mostly informational for any other Bitdefender users here: I reported this incident to Bitdefender support. They are following up, and the install issue will eventually be resolved on their end. For now, I have not found a workable solution other than uninstalling Bitdefender 2017. Bitdefend...
by Jamil
Wed Oct 26, 2016 6:33 pm
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

Re: NullPointerException During Install

The trouble is all due to this newer 2017 Bitdefender. With it uninstalled, oxygen installs without issue as it always has in the past.
by Jamil
Wed Oct 26, 2016 6:28 pm
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

Re: NullPointerException During Install

Hi, This may not be related, but I see you have the temporary folder on a Z: drive (Z:\Temp). Is this a local drive, ramdrive or maybe a network drive? I see you're also running the installer directly from a network share "\\QNAPNAS\Installables\Installs\oXygen\oxygen-64bit.exe". This can be proble...
by Jamil
Wed Oct 26, 2016 5:26 pm
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

Re: NullPointerException During Install

Bitdefender's ransomware now defaults to disabled after install. It is not turned on. I see no information showing that it blocked the oxygen install.
by Jamil
Wed Oct 26, 2016 5:14 pm
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

Re: NullPointerException During Install

I think this may be due to the latest Bitdefender update I also installed. Bitdefender thought that oxygen install was ransomware previously. I will disable it then try again.
by Jamil
Wed Oct 26, 2016 5:13 pm
Forum: Other Issues
Topic: NullPointerException During Install
Replies: 11
Views: 3905

NullPointerException During Install

I setup new hard drives in my workstation and have to reinstall everything. I am attempting to install oxygen 18.1 enterprise and see an NPE. Attached is the log created in the directory where oxygen-64bit.exe exists: install4jError4740116636648712473.log: Exception: java.lang.NullPointerException a...
by Jamil
Tue Sep 13, 2016 8:13 pm
Forum: General XML Questions
Topic: Help with XSL to render XML "Cousins"
Replies: 1
Views: 2607

Re: Help with XSL to render XML "Cousins"

I am reading this during my lunch break, and decided to post some thoughts here. Usually posts such as yours usually will not get a response from my experience. Why? There's plenty of resources available all over to get you started. From looking at what you have posted, no one will really be able to...
by Jamil
Thu Aug 18, 2016 3:22 am
Forum: General XML Questions
Topic: Adding an Animated Gif to my DITA project for Oxygen webhelp
Replies: 1
Views: 2959

Re: Adding an Animated Gif to my DITA project for Oxygen webhelp

Have you tried what is documented here? https://docs.oasis-open.org/dita/v1.1/O ... image.html

It looks like it should be simple enough if added within the body:

Code: Select all

<image href="image.gif" placement="break"><alt>Alternate Text</alt></image>
by Jamil
Sun Jul 31, 2016 2:50 am
Forum: XSLT and FOP
Topic: Convert lower to upper case for XML element without any attributes
Replies: 2
Views: 10438

Re: Convert lower to upper case for XML element without any attributes

I simplified your XSLT quite a bit. Try this: <?xml version="1.0" encoding="UTF-8"?> <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:xhtml="http://www.w3.org/1999/xhtml"> <xsl:output method="xml" encoding="UTF-8"/> <xsl:variable name="smallCase" select="'abcdefgh...
by Jamil
Sat Jul 30, 2016 7:07 pm
Forum: XSLT and FOP
Topic: Convert lower to upper case for XML element without any attributes
Replies: 2
Views: 10438

Re: Convert lower to upper case for XML element without any attributes

The reason this is not working is that you have a template match on text(). This will match on all text in your XML input, and it will not be overridden. You will need to do this a different way. Since you have a known set of nodes and attributes, I would suggest you limit your matches to those defi...
by Jamil
Sat Jul 30, 2016 5:58 pm
Forum: General XML Questions
Topic: Split String To Array Using XPATH
Replies: 1
Views: 7758

Re: Split String To Array Using XPATH

<?xml version="1.0" encoding="UTF-8"?> <root> <string>123456789012345678901234567890</string> </root> <?xml version="1.0" encoding="UTF-8"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:xs="http://www.w3.org/2001/XMLSchema" exclude-result-prefixes="xs" version="1.0"> <xsl:...
by Jamil
Mon May 26, 2014 5:28 pm
Forum: Common Problems
Topic: XML Editor 16.0, build 2014052022 Does Not Start On Workstat
Replies: 23
Views: 6262

Re: XML Editor 16.0, build 2014052022 Does Not Start On Work

I renamed the file specified above to deploy.jar.old. This does nothing to resolve this does nothing to resolve the issue. Additionally, I always start oxygen editor after a new install to fix my toolbars. I did this with the initial build of 16.0. Per my email, if you makr the build available for d...
by Jamil
Fri May 23, 2014 2:39 pm
Forum: Common Problems
Topic: XML Editor 16.0, build 2014052022 Does Not Start On Workstat
Replies: 23
Views: 6262

Re: XML Editor 16.0, build 2014052022 Does Not Start On Work

There is no significant difference between the initial build (2014051618) and new build (2014052022) of v16.0. Most patches from the new build are for WebHelp. Did you maybe install it in a different folder the first time around? Was it the same architecture (32/64 bit)? When you updated to the new...