Search found 18 matches

by DrStrangelove
Thu Jan 10, 2019 6:28 pm
Forum: Common Problems
Topic: Sudden transformation problem
Replies: 2
Views: 1053

Re: Sudden transformation problem

One of our build experts reports that he has solved this problem. He says that changing args.input from ${cf} to ${pd}/${cfne} has fixed the problem. He says: "The args.input value was causing the problem because it made Oxygen use the user's temporary dir in AppData as the output directory. Changin...
by DrStrangelove
Thu Jun 28, 2018 11:09 pm
Forum: Common Problems
Topic: Sudden transformation problem
Replies: 2
Views: 1053

Sudden transformation problem

We are stumped with a transformation problem that started occurring early today. Yesterday it was working fine, as usual. I tried backing out the xpr and ditamap changes that occurred after the last good build, but we still have the same problem. Most of us are on Editor 19 or 19.1, but between the ...
by DrStrangelove
Wed Jun 06, 2018 6:29 pm
Forum: Common Problems
Topic: Webhelp indexterm search is slow - how to optimize?
Replies: 5
Views: 1466

Re: Webhelp indexterm search is slow - how to optimize?

Thank you for looking into this. The new code is a BIG improvement! FYI, there were some character sequences that were not valid in XML, so I had to use CDATA. The two changed lines are: if (inputValue != '' <![CDATA[&&]]> inputValue.length >= oldLength) { and if (inputValue != '' <![CDATA[&&]]> inp...
by DrStrangelove
Tue Jun 05, 2018 4:35 pm
Forum: Common Problems
Topic: Webhelp indexterm search is slow - how to optimize?
Replies: 5
Views: 1466

Re: Webhelp indexterm search is slow - how to optimize?

To Ionela Istodor , can you tell me what is considered a medium-size project? At what size is the index lookup expected to degrade, and is there a way to remediate it?
by DrStrangelove
Thu May 31, 2018 4:37 pm
Forum: Common Problems
Topic: Webhelp indexterm search is slow - how to optimize?
Replies: 5
Views: 1466

Re: Webhelp indexterm search is slow - how to optimize?

Hi Ionela, the help on your web site works fine. What do you consider a moderately sized project? Our output from the Web Help Classic transformation is 70.9 MB, and has 4848 files in 782 folders.
by DrStrangelove
Wed May 30, 2018 8:56 pm
Forum: Common Problems
Topic: How to easily change toc tab label to "Contents" ?
Replies: 1
Views: 744

How to easily change toc tab label to "Contents" ?

We are using WebHelp Classic and 19.1, and want to change the default label for the TOC content tab from "Content" to "Contents". I have not found a way to do this. Is there an easy way to do this in the css?
by DrStrangelove
Wed May 30, 2018 6:18 pm
Forum: Common Problems
Topic: Webhelp indexterm search is slow - how to optimize?
Replies: 5
Views: 1466

Webhelp indexterm search is slow - how to optimize?

We are using Oxygen 19.1 and WebHelp Classic. We are finding that the indexterm search is quite slow, and were wondering if there's a way to speed it up. This is the search from the "Index" tab. When you type a word into the search box, the word does not appear in the box for about 8-10 seconds, and...
by DrStrangelove
Fri Mar 30, 2018 6:59 pm
Forum: Common Problems
Topic: How to display the build date in WebHelp Classic?
Replies: 1
Views: 813

How to display the build date in WebHelp Classic?

I'm using WebHelp Classic and want to display the build date (the date the transformation was run) in the html output. I tried doing the following: 1) On the Transformation Parameters dialog, click New, then enter the parameter name (args.sysdate) and value (${date(yyyy-MM-dd)}). 2) In the ...DITA-t...
by DrStrangelove
Wed Mar 28, 2018 8:16 pm
Forum: Common Problems
Topic: How to suppress panes in WebHelp?
Replies: 1
Views: 757

How to suppress panes in WebHelp?

We have help that is built using WebHelp Classic, and we use index.htm. Normally, we want (and get) the top, left, and content panes. However, when selecting one particular topic, we just want to see the content, not the top or left panes. But all the panes are always showing up. (Parenthetically, I...
by DrStrangelove
Wed Mar 14, 2018 6:11 pm
Forum: Common Problems
Topic: Problem running ditaWebhelp.bat
Replies: 2
Views: 935

Re: Problem running ditaWebhelp.bat

I added this line to my bat file: -lib "%DITA_OT_INSTALL_DIR%\plugins\com.elovirta.ooxml\lib\ant-contrib-0.6.jar"^ but now I am getting this error: check-license: [echo] Using directory C:\Program Files\Oxygen XML Author 19\frameworks\dita\DITA-OT2.x\plugins\com.oxygenxml.webhe lp.classic/lib BUILD ...
by DrStrangelove
Tue Mar 13, 2018 9:35 pm
Forum: Common Problems
Topic: Problem running ditaWebhelp.bat
Replies: 2
Views: 935

Problem running ditaWebhelp.bat

I am trying to run a transformation from the command line following the instructions in https://www.oxygenxml.com/doc/versions/19.1/ug-editor/topics/running-dita-transformation-webhelp-plugin.html but am having a problem. I went to my Oxygen XML Author 19\frameworks\dita\DITA-OT2.x\plugins\com.oxyge...
by DrStrangelove
Fri Feb 09, 2018 8:58 pm
Forum: Common Problems
Topic: importance="optional" for li ?
Replies: 2
Views: 822

Re: importance="optional" for li ?

Thank you!
by DrStrangelove
Thu Feb 08, 2018 8:23 pm
Forum: Common Problems
Topic: importance="optional" for li ?
Replies: 2
Views: 822

importance="optional" for li ?

We recently converted our content to Dita. Some of our tasks correctly use steps/step but many are still using ul/li. We eventually intend to convert them but that cannot be completed in the available timeframe. We want optional steps to be labelled as "Optional:" regardless of whether the importanc...
by DrStrangelove
Wed Feb 07, 2018 11:43 pm
Forum: Common Problems
Topic: How to override the menucascade-separator?
Replies: 2
Views: 976

How to override the menucascade-separator?

The default menucascade-separator looks like an angle bracket with a dotted line underneath. I'd like to change it to just the angle bracket, and to specify that in the css file. I tried the following, and it did add an angle bracket, but it also retained the default separators, so there were two se...
by DrStrangelove
Sat Jan 27, 2018 12:16 am
Forum: Common Problems
Topic: Profiling condition sets at the project level do not work
Replies: 4
Views: 1083

Re: Profiling condition sets at the project level do not work

I think I have a solution. I can specify ditavalref in my ditamap, for example: <ditavalref href="feature-toggles.ditaval"/>
And still have a ditaval filter on the transformation for that map.
by DrStrangelove
Fri Jan 26, 2018 5:16 pm
Forum: Common Problems
Topic: Profiling condition sets at the project level do not work
Replies: 4
Views: 1083

Re: Profiling condition sets at the project level do not work

Hi Sorin, thanks for your reply. As it turns out, while testing, I had updated my global transformation to use the same filter as the one I used for the condition set. That's why it worked in the global context. But I am still trying to solve a problem related to condition sets. Under a project, we ...
by DrStrangelove
Thu Jan 25, 2018 11:34 pm
Forum: Common Problems
Topic: Profiling condition sets at the project level do not work
Replies: 4
Views: 1083

Profiling condition sets at the project level do not work

Our group would like to be able to toggle text based on a feature ID. To do this, I created a ditaval file whose entries have att="otherprops" , val = the feature ID, and the appropriate action. I went to Profiling/Conditional Text, and under Profiling Condition Sets, I specified this ditaval file. ...