Search found 10 matches

by felix1845
Wed Jun 14, 2017 9:17 pm
Forum: General XML Questions
Topic: Putting the xml into a website
Replies: 10
Views: 1236

Re: Putting the xml into a website

What do you mean when you say "upload the html and resources"? Are the resources the xslt and css files? I'm working on the Wordpress side of things, but they can't tell me anything about xml. As far as I understand it, the xml file is meaningless without the xslt and the css to interpret ...
by felix1845
Wed Jun 07, 2017 10:44 pm
Forum: General XML Questions
Topic: Putting the xml into a website
Replies: 10
Views: 1236

Re: Putting the xml into a website

Hi, The second one: I want to link to the HTML. I've checked it, by clicking on the Transformation Scenario, which then makes it appear in a tab of the browser. Is that what you meant? And it looks fine there. But now this tab is called file:///C:/Users/aliso/Desktop/DH%20work/TEI/Marginalia%20in%20...
by felix1845
Tue Jun 06, 2017 5:23 pm
Forum: General XML Questions
Topic: Putting the xml into a website
Replies: 10
Views: 1236

Re: Putting the xml into a website

Well, I talked to the Wordpress people and they looked at the site and said it's definitely not their system, but the file itself. Which I agree with; I think I'm doing something wrong with the process of converting an xml document to html with xslt. So I have xml, xsl and css, and they're all separ...
by felix1845
Tue Jun 06, 2017 5:02 am
Forum: General XML Questions
Topic: Putting the xml into a website
Replies: 10
Views: 1236

Re: Putting the xml into a website

Can you clarify this? I have an xml document that has been converted to html with xslt. But this is still a file which I can't put onto a website, so there must be another step.

Thanks,
Alison
by felix1845
Mon Jun 05, 2017 6:04 pm
Forum: General XML Questions
Topic: Putting the xml into a website
Replies: 10
Views: 1236

Re: Putting the xml into a website

Hi,

So I converted the xml to html using an xslt stylesheet, but the link in the browser still won't work when I try to make it a link on the website. What do you mean when you say "upload the html document"? Do you mean the xslt stylesheet? And I should upload this to Wordpress?

Alison
by felix1845
Sun Jun 04, 2017 3:25 am
Forum: XSLT and FOP
Topic: Adding a CSS stylesheet to xml
Replies: 1
Views: 688

Adding a CSS stylesheet to xml

I am very confused about using a css stylesheet to alter the formatting of xml in a browser. I have an xslt stylesheet, and that works fine, but the css doesn't appear to make any difference. At the top I have <?xml-stylesheet href="text.css" type="text/css"?>. Is this wrong? The...
by felix1845
Sat Jun 03, 2017 4:39 am
Forum: General XML Questions
Topic: Putting the xml into a website
Replies: 10
Views: 1236

Putting the xml into a website

I have a wordpress account and would like to link the xml I made there. I have a stylesheet so I know it can be read in a browser, but copying and pasting the link created with "Transformation Scenario" doesn't work. Am I missing something straightforward?
by felix1845
Tue May 30, 2017 7:58 pm
Forum: XSLT and FOP
Topic: Mycontent not showing up when I use the xslt stylesheet
Replies: 2
Views: 865

Re: Mycontent not showing up when I use the xslt stylesheet

That works! The formatting's all to hell, but I can figure that out. Thanks!
by felix1845
Tue May 30, 2017 5:06 pm
Forum: XSLT and FOP
Topic: Mycontent not showing up when I use the xslt stylesheet
Replies: 2
Views: 865

Mycontent not showing up when I use the xslt stylesheet

I made an xsl stylesheet and followed all the instructions in a tutorial I found online. It showed me this: <?xml version = "1.0" encoding = "UTF-8"?> <xsl:stylesheet version = "1.0" xmlns:xsl = "http://www.w3.org/1999/XSL/Transform"> <xsl:template match = &qu...
by felix1845
Mon May 29, 2017 10:49 pm
Forum: Common Problems
Topic: "the markup in the document following the root element must be well-formed"
Replies: 1
Views: 3787

"the markup in the document following the root element must be well-formed"

I keep getting this error: "the markup in the document following the root element must be well-formed" But I've checked all over, and I can't find the non-well-formed element. When I click on the message, it brings me to the first line of the document (after the stylesheet information) whi...

Go to advanced search