Search found 7 matches

by Dill
Sat Sep 17, 2016 10:30 pm
Forum: Common Problems
Topic: Using an XQuery //foo/@bar gives "Your query returned an empty sequence."
Replies: 6
Views: 817

Re: Using an XQuery //foo/@bar gives "Your query returned an empty sequence."

I have the same problem.

imo error "XPTY0004: Cannot create an attribute node whose parent is a document node" should be returned.
by Dill
Mon Sep 12, 2016 4:55 pm
Forum: Common Problems
Topic: How to delete an attribute from some elements selected by XPath?
Replies: 4
Views: 881

Re: How to delete an attribute from some elements selected by XPath?

You could also use xquery update for tasks like this.
In the xquery builder select saxon EE and in settings check "enable xq update" and "use linked tree model" and enter the code

Code: Select all

delete nodes doc(<your-document>)/<your-xpath>
by Dill
Mon Sep 12, 2016 4:02 pm
Forum: Common Problems
Topic: limitations of saxonn-ee licence coming with oxygen
Replies: 4
Views: 597

Re: limitations of saxonn-ee licence coming with oxygen

thanks its working now.
by Dill
Mon Sep 12, 2016 1:32 pm
Forum: Common Problems
Topic: limitations of saxonn-ee licence coming with oxygen
Replies: 4
Views: 597

Re: limitations of saxonn-ee licence coming with oxygen

Saxon extension functions already work ... right, I just tried the wrong function: declare namespace file = "http://expath.org/ns/file"; file:base-dir() results in the error: "Cannot find a matching 0-argument function named {http://expath.org/ns/file}base-dir()" while it works ...
by Dill
Sat Sep 10, 2016 2:00 pm
Forum: Common Problems
Topic: limitations of saxonn-ee licence coming with oxygen
Replies: 4
Views: 597

limitations of saxonn-ee licence coming with oxygen

I'm evaluating oxygen developer. If I understand correctly it comes with a full saxon EE (usable only inside oygen). But I can't use all the EE features. eg XQuery 3.1 (Schema Aware) and Saxon extension functions (Basic+Adavanced) are not avaiable, while the EE features XQuery Update 1.0 and higher ...
by Dill
Wed Aug 24, 2016 12:47 pm
Forum: XQuery
Topic: XQuery Debugger
Replies: 1
Views: 1192

XQuery Debugger

Hi, I'm just evaluating oxygen and I like it a lot, but I'm struggling with the debugger. First of all when I step through the code, it jumps around wildly. I understand, that XQuery is not a imperative language, but why arent't for example even successive let-clauses processed in order...? Also it'...
by Dill
Tue Aug 23, 2016 8:13 pm
Forum: XQuery
Topic: XProc and XQuery
Replies: 1
Views: 717

XProc and XQuery

I try to run xquery from xproc. But with the files below I get the error "Content is not allowed in prolog" in the file hello.xquery. It seems like a wrong saxon version is used (which can't handle xquery) What to do? <?xml version="1.0" encoding="UTF-8"?> <test>Hello, ...

Go to advanced search