Search found 25 matches

by caval
Wed May 03, 2017 10:25 pm
Forum: Common Problems
Topic: [BUG] Webhelp Responsive chunking not working
Replies: 3
Views: 410

Re: [BUG] Webhelp Responsive chunking not working

Hi Costoi, Thanks for your very cogent response. I added fix.external.refs.com.oxygenxml=true to the properties file, but the chunks are still not created. I also 1) validated the map and 2) created a very simple map as an alternate test -- in both cases the chunks are not created. However, when I r...
by caval
Tue May 02, 2017 7:39 pm
Forum: Common Problems
Topic: [BUG] Webhelp Responsive chunking not working
Replies: 3
Views: 410

Re: [BUG] Webhelp Responsive chunking not working

More information from the output messages The output messages include the following: chunk-check: chunk: There is, however, no output under the chunk heading. Conversely, when the build is run on the local PC from Oxygen, there are numerous lines under the chunk heading, such as the following: [chun...
by caval
Tue May 02, 2017 7:26 pm
Forum: Common Problems
Topic: [BUG] Webhelp Responsive chunking not working
Replies: 3
Views: 410

Re: [BUG] Webhelp Responsive chunking not working

Fixed typos/added clarification: I am running the webhelp plugin v19 in an external OT process. Many topics in the ditamap are chunked (chunk="to-content"). In testing, when I ran the build from Oxygen on a local PC, the chunks were resolved correctly. However, after I moved the OT to an e...
by caval
Wed Apr 19, 2017 5:33 pm
Forum: Feature Request
Topic: Add scroll up button to webhelp
Replies: 5
Views: 794

Re: Add scroll up button to webhelp

This seems like a very good solution. Thanks. Is there any chance that this will be added to some future build as a regular option in webhelp?
by caval
Thu Apr 13, 2017 12:04 am
Forum: Feature Request
Topic: Add scroll up button to webhelp
Replies: 5
Views: 794

Add scroll up button to webhelp

I notice the oxygenxml.com pages have a button that appears on scroll down. When clicked, the page jumps to the top.

This is a very common feature of modern websites but is missing from the webhelp (as of v19).
by caval
Wed Apr 12, 2017 6:48 pm
Forum: Common Problems
Topic: Bug: Webhelp 19 exact phrase search
Replies: 2
Views: 354

Bug: Webhelp 19 exact phrase search

Let me begin by expressing my congratulations for webhelp 19! The new search features are a huge improvement and make the webhelp much more usable and modern. However, I did notice an issue with exact phrase searches. If a term contains punctuation, no results are returned. For example: "index....
by caval
Wed Nov 16, 2016 11:29 pm
Forum: Common Problems
Topic: SVG and img tag
Replies: 2
Views: 559

Re: SVG and img tag

Thanks very much Radu.
by caval
Mon Oct 03, 2016 4:46 pm
Forum: Common Problems
Topic: SVG and img tag
Replies: 2
Views: 559

SVG and img tag

In webhelp 17.1 output, SVG images are rendered using the <img> tag rather than the recommended <object> tag. The problem is that if the SVG is edited and effects such as mouseover are added using CSS/scripting, these effects are not supported with the <img> tag. They only render correctly with the ...
by caval
Wed Apr 27, 2016 9:47 pm
Forum: Common Problems
Topic: [BUG] Chunked webhelp topics have no associated CSS
Replies: 6
Views: 743

Re: [BUG] Chunked webhelp topics have no associated CSS

Addendum: None of the resources on the chunked page are referenced correctly (i.e. CSS and javascript).
by caval
Wed Apr 27, 2016 9:41 pm
Forum: Common Problems
Topic: [BUG] Chunked webhelp topics have no associated CSS
Replies: 6
Views: 743

[BUG] Chunked webhelp topics have no associated CSS

When the chunk="to-content" AVP is applied to a topicref with sub-topics in a map, the webhelp output is correctly chunked -- all sub-topics appear on the same page -- but the chunked page has no associated CSS. When a standard Inspect Element tool is used on the page, no associated CSS fi...
by caval
Tue Aug 04, 2015 7:13 pm
Forum: Common Problems
Topic: Webhelp compatibility problem with Internet Explorer 11?
Replies: 5
Views: 1198

Re: Webhelp compatibility problem with Internet Explorer 11?

Thanks. The problem was that our internal documentation site was displayed using IE11 compatibility view; intranet sites normally use compatibility view in IE11 by default. If the site is removed from compatibility view, it displays normally in IE11. This problem also occurs if http://www.oxygenxml....
by caval
Thu Jul 30, 2015 5:57 pm
Forum: Common Problems
Topic: Webhelp compatibility problem with Internet Explorer 11?
Replies: 5
Views: 1198

Webhelp compatibility problem with Internet Explorer 11?

Background We have recently upgraded our webhelp plugin from v16 to v17. With v16, our webhelp output could be viewed successfully using IE 9 and up. Our site is quite large but the ditamap is very straightforward. Problem Now, when generating the webhelp with an unmodified v17 webhelp plugin, the ...
by caval
Fri Jul 24, 2015 5:27 am
Forum: XSLT and FOP
Topic: WebHelp v17 with Saxon-PE in external OT?
Replies: 1
Views: 514

WebHelp v17 with Saxon-PE in external OT?

Simple question: The Oxygen online help states that Saxon-B 9.1.0.8 is a requirement for integrating webhelp into an external OT. We cannot use this version of Saxon in our external OT. Can we instead use Saxon-PE 9.6.x?

Thanks...!
by caval
Thu May 14, 2015 4:50 pm
Forum: Common Problems
Topic: Customizing search results using keywords
Replies: 5
Views: 1193

Re: Customizing search results using keywords

Thanks Radu. This solution works well in our tests.
by caval
Wed May 13, 2015 7:09 pm
Forum: Common Problems
Topic: External OT - Custom PDF transform fails with Oxygen 17.0
Replies: 5
Views: 1106

Re: External OT - Custom PDF transform fails with Oxygen 17.

The issue has been solved. This jar was left off the classpath: - ${configured.ditaot.dir.url}/plugins/org.dita.pdf2/fop/build/fop.jar The source of the confusion was that, previously with our Oxygen 16.1 transform, we did not reference fop.jar and it did work fine. The fop jars and the other jars i...
by caval
Wed May 13, 2015 6:24 pm
Forum: Common Problems
Topic: External OT - Custom PDF transform fails with Oxygen 17.0
Replies: 5
Views: 1106

Re: External OT - Custom PDF transform fails with Oxygen 17.

Thanks Radu! I should clarify a few things: * We left all options on the Preferences > DITA page at default * In 16.1 transform, we did use the {dita.dir.url} parameter * In 17.0 transform, this parameter did not expand correctly so we are using the {configured.ditaot.dir.url} parameter, which does ...
by caval
Wed May 13, 2015 1:05 am
Forum: Common Problems
Topic: External OT - Custom PDF transform fails with Oxygen 17.0
Replies: 5
Views: 1106

Re: External OT - Custom PDF transform fails with Oxygen 17.

Also, we are using:
- JRE 1.8 (also tested on 1.7 with same result)
- FOP 1.1
by caval
Wed May 13, 2015 12:56 am
Forum: Common Problems
Topic: External OT - Custom PDF transform fails with Oxygen 17.0
Replies: 5
Views: 1106

External OT - Custom PDF transform fails with Oxygen 17.0

Background Currently we use Oxygen 16.1. Our custom PDF plugin is in an external OT (v1.7) and works with no problems. Our custom transform scenario references jars in the external OT rather than those in the Oxygen path. We downloaded a trial of Oxygen 17.0 to test it with our PDF plugin. We repli...
by caval
Mon May 11, 2015 8:43 pm
Forum: Common Problems
Topic: Customizing search results using keywords
Replies: 5
Views: 1193

Re: Customizing search results using keywords

Greetings,

Was this update enabling search for strings of 2 characters (such as Gx, Gy, Sy, etc.) included in the recent v17 of the webhelp?
by caval
Tue Mar 10, 2015 4:56 pm
Forum: Common Problems
Topic: Customizing search results using keywords
Replies: 5
Views: 1193

Re: Customizing search results using keywords

I noticed in your documentation that you do point out this limitation of 3 or more characters. Fair enough. I'm still wondering if there is a way to force indexing of certain keywords that are only 2 chars.
by caval
Tue Mar 10, 2015 4:51 pm
Forum: Common Problems
Topic: Customizing search results using keywords
Replies: 5
Views: 1193

Customizing search results using keywords

We've noticed that the threshold for the search indexing seems to be 3 chars or greater. So the 3GPP S6a interface is indexed and shows up in the search results, but the S9 interface does not appear. Based on other posts suggesting that adding metadata keywords is a way to prioritize search results,...
by caval
Thu Mar 05, 2015 7:03 pm
Forum: Common Problems
Topic: Bug: Relative links on page broken in webhelp 16.1
Replies: 3
Views: 800

Re: Bug: Relative links on page broken in webhelp 16.1

Thanks very much Sorin. The patch works perfectly.
by caval
Thu Mar 05, 2015 12:07 am
Forum: Common Problems
Topic: Bug: Relative links on page broken in webhelp 16.1
Replies: 3
Views: 800

Re: Bug: Relative links on page broken in webhelp 16.1

I can confirm that this problem does not occur with IE 8. This is interesting because IE 8 does not fully support html5.
by caval
Wed Mar 04, 2015 11:58 pm
Forum: Common Problems
Topic: Bug: Relative links on page broken in webhelp 16.1
Replies: 3
Views: 800

Bug: Relative links on page broken in webhelp 16.1

Relative links to object ids on a page are broken when webhelp is generated from DITA using Oxygen 16.1. These links functioned correctly in Oxygen 15. This is how the webhelp outputs a relative link: <p class="p">Link to section: <a class="xref" href="#concept110__sec1"...
by caval
Tue Jan 27, 2015 9:17 pm
Forum: Other Issues
Topic: Build Failed! with external DITA-OT 2.0
Replies: 15
Views: 3557

Build Failed! with external DITA-OT 2.0

I am attempting to run a transform from Oxygen 16.1 using a custom PDF plugin. This process works successfully in OT v1.7 and v1.8 but I am having some trouble getting it working with OT v2.0. These are the steps I’ve taken so far: • moved custom build scripts into new OT • moved custom PDF plugin i...

Go to advanced search