Search found 5 matches

by wolandscat
Fri Nov 01, 2013 4:26 pm
Forum: XQuery
Topic: Passing directory parameter to Xquery from Trans Scenario
Replies: 4
Views: 4357

Re: Passing directory parameter to Xquery from Trans Scenari

Yes, I discovered that does happen, and seems to work when you follow the Oxygen proper workflow. It wasn't that obvious initially, because there is a lot on the screen in Oxygen. I'm still not completely sure I understand how Oxygen 'knows' when there really is a binding between a given Xquery and ...
by wolandscat
Wed Oct 30, 2013 6:36 pm
Forum: XQuery
Topic: Passing directory parameter to Xquery from Trans Scenario
Replies: 4
Views: 4357

Re: Passing directory parameter to Xquery from Trans Scenari

Hi, thanks for the answer. I have added the declaration to the xquery. In the transformation scenario, I added a variable 'test_set' and a value for it. (It's not clear whether it should be 'test_set', '{test_set}', '$test_set', '${test_set}' or something else). When I run the scenario, I get the er...
by wolandscat
Tue Oct 29, 2013 6:33 pm
Forum: XQuery
Topic: Passing directory parameter to Xquery from Trans Scenario
Replies: 4
Views: 4357

Passing directory parameter to Xquery from Trans Scenario

Oxygen 15 / Windows 7 I have an Xquery that starts with the statement: for $file in collection("../test_set_001/?select=*.xml"); this finds all the XML files in the directory test_set_001 and runs the remaining statements on them. What I really want is to be able to set up different Transf...
by wolandscat
Thu Oct 03, 2013 9:40 pm
Forum: Common Problems
Topic: Can't make XQuery do anything
Replies: 2
Views: 1038

Re: Can't make XQuery do anything

I finally figured this out after doing a textbook example out of desperation. I don't usually work directly in XML, and it always mystifies me when a namespace that is declared in a document isn't the assumed namespace for references (like paths) in a query or other doc, which is processing that doc...
by wolandscat
Thu Oct 03, 2013 1:50 am
Forum: Common Problems
Topic: Can't make XQuery do anything
Replies: 2
Views: 1038

Can't make XQuery do anything

[Windows 7 / Oxygen Editor v15] I have a very simple Xquery: for $x in doc("../openHR_test_set_001/039dec8d-7b2b-485d-be37-ff5e29645e71.xml")/openHealthRecord return $x/id The start of the data looks as follows: <?xml version="1.0"?> <openHealthRecord xmlns:xsi="http://www.w...

Go to advanced search