Search found 60 matches

by dnedrow
Sat Dec 29, 2012 4:26 am
Forum: Common Problems
Topic: Do the proxy settings work for anyone?
Replies: 2
Views: 5804

Re: Do the proxy settings work for anyone?

If the HTTP proxy requires NTLM authentication then that's the problem. The current version of Oxygen (v14.1) doesn't support NTLMv2 and it seems NTLMv1 doesn't work correctly either with Windows Server 2008 and later. Only basic and digest authentication methods work correctly. We have already add...
by dnedrow
Fri Dec 14, 2012 8:48 pm
Forum: Common Problems
Topic: Do the proxy settings work for anyone?
Replies: 2
Views: 5804

Do the proxy settings work for anyone?

I'm having a problem with a corporate proxy. I've seen similar issues in the forums, but it seems as though — if they're resolved — the solution(s) don't generally make it into the thread. oXygen 14.1 Windows 7 Internal http proxy Problem: I'm unable to validate any markup that uses an external sche...
by dnedrow
Tue Jan 03, 2012 7:20 pm
Forum: Feature Request
Topic: Format and Indent Toggle
Replies: 5
Views: 2738

Re: Format and Indent Toggle

Thanks for the reply Adrian. I was afraid that formatting was handled exactly the way you described, which would be the "correct" way. ;) I can see where implementing what I would like would be problematic. Just in case anyone is trying to accomplish the same thing, here's my plan... I'll write a cv...
by dnedrow
Thu Dec 29, 2011 7:24 pm
Forum: Feature Request
Topic: Format and Indent Toggle
Replies: 5
Views: 2738

Re: Format and Indent Toggle

dnedrow wrote:Perhaps when oXygen were to see <!-- O- -->, it would stop formatting, then re-enable formatting when it comes across <!-- O- -->.
Oop, this should be ...
Perhaps when oXygen were to see <!-- O- -->, it would stop formatting, then re-enable formatting when it comes across <!-- O+ -->.
by dnedrow
Thu Dec 29, 2011 7:21 pm
Forum: Feature Request
Topic: Format and Indent Toggle
Replies: 5
Views: 2738

Re: Format and Indent Toggle

The problem is that even when I have preserve set, portions of a "preserved" element are still modified by pretty print. The original ... <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE project [ <!ATTLIST project xml:space (default|preserve) 'preserve'> <!ATTLIST target xml:space (default|preserve...
by dnedrow
Wed Dec 28, 2011 2:05 am
Forum: Feature Request
Topic: Format and Indent Toggle
Replies: 5
Views: 2738

Format and Indent Toggle

(Jump in if there's a feature in oxygen that I've missed which does what I'm asking below) I tried the xml:space attribute declaration thinking I would be able to basically use it as a toggle for pretty print. Eg., for an ant build file, <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE project [ <!A...
by dnedrow
Fri May 02, 2008 3:32 pm
Forum: Common Problems
Topic: v9.1 won't launch with 64-bit Java 6 or 5 on OS X
Replies: 4
Views: 2536

SOLVED: Re: v9.1 won't launch with 64-bit Java 6 or 5 on OS

It looks as though something in my oXygen tree was missing or corrupt. I re-extracted the archive and the contained oXygen ran fine, though with the missing archs error. You may want to add the following recommended entries to the oXygen info.plist file. Doing so will clear an informational message ...
by dnedrow
Fri May 02, 2008 3:10 pm
Forum: Common Problems
Topic: v9.1 won't launch with 64-bit Java 6 or 5 on OS X
Replies: 4
Views: 2536

Re: v9.1 won't launch with 64-bit Java 6 or 5 on OS X

Actually, the oXygen plugin is working fine in Eclipse (Eclipse is running in 32-bit mode).

The problem I'm having is the Eclipse standalone application which won't launch.

-David
by dnedrow
Thu May 01, 2008 6:23 pm
Forum: Common Problems
Topic: v9.1 won't launch with 64-bit Java 6 or 5 on OS X
Replies: 4
Views: 2536

v9.1 won't launch with 64-bit Java 6 or 5 on OS X

Virtually all of my Java applications run fine with the 64-bit versions of Java 5 and 6 under OS X (Leopard). Eclipse, however, won't launch and the following errors show in the system log... 5/1/08 10:35:14 AM [0x0-0x125125].ro.sync.exml.Oxygen[11192] [JavaAppLauncher] A 64-bit JVM is available for...
by dnedrow
Sat Dec 29, 2007 8:34 pm
Forum: Common Problems
Topic: "Open URL..." dialog needs major overhaul
Replies: 1
Views: 1622

"Open URL..." dialog needs major overhaul

The "Open URL..." dialog is one of the worst designed UI elements I've ever seen. ;) Generally, oXygen is well designed, but this particular dialog is frustrating. It appears to be an attempt to provide two distinct operations in a single dialog, one being opening a remote file via URL an the other ...
by dnedrow
Sat Dec 29, 2007 8:23 pm
Forum: Common Problems
Topic: oXygen 9.1+ does not remember ssh keys
Replies: 1
Views: 1613

oXygen 9.1+ does not remember ssh keys

Each time I try to connect to a particular server, oXygen prompts me to accept that servers ssh key. This key should be stored the first time it is accepted, whether the actual connection is successful or not. The user has made the choice to accept the key, and should not be prompted again. I suspec...
by dnedrow
Sat Dec 29, 2007 8:20 pm
Forum: Feature Request
Topic: oXygen 9.1+ should use ~/.ssh/ for sftp keys, etc.
Replies: 3
Views: 3104

oXygen 9.1+ should use ~/.ssh/ for sftp keys, etc.

When oXygen needs to read or store an ssh key for authentication, it should be using files in the user's .ssh directory. Most applications that use ssh features, use the standard files in this directory to retrieve and store public and private keys, etc. This would allow oXygen to "know" about keys ...
by dnedrow
Sat Dec 29, 2007 8:12 pm
Forum: Other Issues
Topic: Unable to open remote files for editing
Replies: 5
Views: 3589

Unable to open remote files for editing

I regularly use BBEdit to edit remote files via sftp, but decided to try to start using oXygen for that purpose, as I really like the validation features as compared to those in BBEdit. Note that my hosting company allows ssh/sftp access, but does not allow ftp and has no webdav support. Hence my ne...
by dnedrow
Wed Aug 30, 2006 6:15 pm
Forum: Common Problems
Topic: Oxygen editor is changing xml code
Replies: 6
Views: 4242

Is this happening when the file is opened, or are you doing a format and indent?

Also, have you double checked that you have the appropriate options selected in the XML->FOrmat prefs?

Eg. 'Preserve text as it is'

-David
by dnedrow
Wed Aug 30, 2006 5:56 pm
Forum: Common Problems
Topic: Catalog questions
Replies: 1
Views: 3156

As an aside, is there an easy way in oXygen to see the catalog/resolution traversal?

-David
by dnedrow
Wed Aug 30, 2006 5:53 pm
Forum: Common Problems
Topic: Catalog questions
Replies: 1
Views: 3156

Catalog questions

This isn't specifically oXygen related, so I can take it to one of the xml lists if necessary. Thought I'd try here first though. :wink: Sun uses a new system for handling services. This system involves DTD-based XML files. I'd like to use oXygen to edit and validate these files. For whatever reason...
by dnedrow
Wed Aug 30, 2006 5:41 pm
Forum: Common Problems
Topic: Oxygen editor is changing xml code
Replies: 6
Views: 4242

Have you tried a single space between the square brackets?
by dnedrow
Thu Mar 02, 2006 6:06 pm
Forum: Feature Request
Topic: "lock" all text
Replies: 1
Views: 4255

"lock" all text

The tag locking in oXygen is nice, but it would also be nice to have a "lock all" feature that would prevent any changes to the open file without actually making the file read-only at the filesystem level. Ideally, this state would be saved somehow so that the locked text status is the same between ...
by dnedrow
Thu Mar 02, 2006 6:02 pm
Forum: Other Issues
Topic: Flag open files "read only"?
Replies: 2
Views: 5257

Cool, thanks.

-David
by dnedrow
Thu Mar 02, 2006 12:10 am
Forum: Other Issues
Topic: Flag open files "read only"?
Replies: 2
Views: 5257

Flag open files "read only"?

Is there a mechanism within oXygen to mark files read only? Note that I want to prevent modifying certain files within oXygen, not at the filesystem level.

-David
by dnedrow
Fri Jan 27, 2006 6:43 am
Forum: XSLT and FOP
Topic: Math characters from isoXXXX.ent
Replies: 1
Views: 2940

Math characters from isoXXXX.ent

I create all of my University papers using DocBook XML, which I then transform via XEP 4.5 (via oXygen). My problem is that in the resulting printable format (PDF, PS), the "Added Math Symbols: Relations" (isoamsr.ent) that I'm referencing are not being displayed/generated in the resulting file. E.g...
by dnedrow
Fri Jan 27, 2006 6:22 am
Forum: XSLT and FOP
Topic: embedding fonts in PDF output
Replies: 10
Views: 10930

catterall wrote:Will this work with XEP as well? (If I have selected XEP in place of FOP in preferences)?
Ron,

I believe font embedding/subsetting is configured in the xep.xml file. Take a look at section 2.4.1.1 of the XEP 4.x Reference.

-David
by dnedrow
Fri Sep 16, 2005 2:42 pm
Forum: Feature Request
Topic: Auto-set for JVM under OS X
Replies: 2
Views: 2810

Cool, that sounds like a reasonable solution.

-David
by dnedrow
Wed Sep 14, 2005 9:08 pm
Forum: Feature Request
Topic: Auto-set for JVM under OS X
Replies: 2
Views: 2810

Auto-set for JVM under OS X

It would be nice if there was some mechanism for setting the JVM for oXygen on first launch. This way, the default VM would be selected rather than defaulting to 1.4*. J2SE 1.50 is coming for OS X and I imagine anyone who uses Java apps will be installing it. At the least, this (the need to edit inf...
by dnedrow
Wed Sep 14, 2005 9:05 pm
Forum: Common Problems
Topic: Where does one set the JVM version for Mac version?
Replies: 2
Views: 1859

info.plist

Rats, that's the one file I didn't look in.

Thanks for the info, I'm all set now.

-David
by dnedrow
Tue Sep 13, 2005 8:03 pm
Forum: Common Problems
Topic: Where does one set the JVM version for Mac version?
Replies: 2
Views: 1859

Where does one set the JVM version for Mac version?

Hmmm, I've installed Java 2 SE 1.5.0 under OS X 10.4.2. In a terminal, java -version shows that I'm finding 1.5.0 as the VM. However, oXygen shows 1.4.2. How/where do I set the JVM in the Mac version of oXygen? Under Linux, I can jimmy the Oxygen.lax file to force the VM, but there's nothing obvious...
by dnedrow
Wed Jul 06, 2005 5:33 am
Forum: Common Problems
Topic: bug oxygen 6.0 on OSX ? last saved document is not visible
Replies: 3
Views: 3312

Re: bug oxygen 6.0 on OSX ? last saved document is not visib

Hello, this most recently saved document does NOT show up in the file selection list when using menu "File - Open" or "Document - XML Document - Associate schema" ... The saved document is shown in Apple's Finder, but Oxygen does obviously not update its file list after saving a document, only the ...
by dnedrow
Mon Jun 20, 2005 10:53 pm
Forum: Feature Request
Topic: How do you pick schemas to bundle?
Replies: 2
Views: 4997

For example we are not aware that the Open Document Format for Office Applications was already adopted on a large scale by XML users. Cool, thanks for the info. OpenDocument looks to be headed for the standard interchange format for office applications (ignoring left-fielder Microsoft), so I imagin...
by dnedrow
Thu Jun 16, 2005 5:39 pm
Forum: Feature Request
Topic: How do you pick schemas to bundle?
Replies: 2
Views: 4997

How do you pick schemas to bundle?

How does SyncRO Soft pick schemas for bundling? Do you look at suggestions from users, anr/or look for worthwhile (to SyncRO Soft) additions? For example, when OpenDocument (OASIS Open Document Format for Office Applications), is this something you would normally look at bundling, or is it more depe...
by dnedrow
Thu Jun 16, 2005 5:31 pm
Forum: General XML Questions
Topic: How does one use tag insite with a non-oXygen schema?
Replies: 17
Views: 20652

The wordnet.xsd schema works with v6 without problems. However, it declares only two global elements and only the global elements are presented by the content completion for XSLT as possible result elements. That sounds like a Microsoft schema. ;) I don't know if you guys have the time to manage so...