[oXygen-user] Setting up and configuring the Idiom FO Plugin in 9.2

Eliot Kimber
Fri May 23 09:22:50 CDT 2008

Using 9.2 I tried to use the Idiom plugin to generate PDF. I had not done
anything to the built-in framework. The transform scenario panel indicated
that XEP was detected, but when I ran it I got a failure saying that it
couldn't find xep/lib in /Applications/DITA-OT1.4.1 (this is on OS X).

I did not have an /Applications/DITA-OT1.4.1 directory on my machine
(although I had in the past).

I did a search within the framework for "DITA-OT1.4.1" and couldn't find it.

I then tried copying a working copy of xep from another Toolkit instance I
had lying about into the framework's fo/lib directory, but no change.

Finally, I created the directory it was looking for and put xep there and
the PDF generation worked.

Clearly there's something odd on my machine that is causing this problem but
I have no idea what it might be. I'm afraid I found the online help for
setting up the Idiom plugin a bit confusing (although I find the plugin
itself a bit confusing).

I didn't see any configuration settings that would have been pointing at

Is it possible this is actually a bug in the plugin as distributed that was
simply masked by the fact that the target directory exists on the machine(s)
used to test Oxygen? I would have never noticed the problem if I had kept my
1.4.1 Toolkit around.


Eliot Kimber
Senior Solutions Architect
"Bringing Strategy, Content, and Technology Together"
Main: 610.631.6770

More information about the oXygen-user mailing list