[oXygen-user] Setting up and configuring the Idiom FO Plugin in 9.2

Sorin Ristache
Fri May 23 10:10:43 CDT 2008


When the error message contains a string like 
"frameworks\dita\DITA-OT\demo\fo\lib\xep\lib not found." usually the 
cause is a missing XEP installation.

Why does the error message refer to an /Applications/DITA-OT1.4.1 
directory instead of /Applications/Oxygen/frameworks/dita/DITA-OT? Did 
you set an external DITA-OT in the scenario instead of the built-in one 
in the Advanced tab of the DITA scenario dialog or in the dita.dir 
parameter of the DITA build script (the Parameters tab of the DITA 
scenario dialog)? In that case please note that XEP cannot be used with 
the Idiom plugin in DITA-OT out of the box. We customized the built-in 
DITA-OT distribution that comes with Oxygen/Author to allow that.

If you use the built-in DITA-OT (that is you have 
${frameworksDir}/dita/DITA-OT/build.xml in the Advanced tab of the DITA 
scenario dialog and you did not change the dita.dir parameter) and the 
FO Processor tab of the DITA scenario dialog specifies in the "Detected 
XEP directory" label under the Processor combo box a file path where XEP 
really is installed then it looks like a bug in the detection of XEP. If 
XEP is not installed the label should say "Not available".


Eliot Kimber wrote:
> Using 9.2 I tried to use the Idiom plugin to generate PDF. I had not done
> anything to the built-in framework. The transform scenario panel indicated
> that XEP was detected, but when I ran it I got a failure saying that it
> couldn't find xep/lib in /Applications/DITA-OT1.4.1 (this is on OS X).
> I did not have an /Applications/DITA-OT1.4.1 directory on my machine
> (although I had in the past).
> I did a search within the framework for "DITA-OT1.4.1" and couldn't find it.
> I then tried copying a working copy of xep from another Toolkit instance I
> had lying about into the framework's fo/lib directory, but no change.
> Finally, I created the directory it was looking for and put xep there and
> the PDF generation worked.
> Clearly there's something odd on my machine that is causing this problem but
> I have no idea what it might be. I'm afraid I found the online help for
> setting up the Idiom plugin a bit confusing (although I find the plugin
> itself a bit confusing).
> I didn't see any configuration settings that would have been pointing at
> DITA-OT1.4.1.
> Is it possible this is actually a bug in the plugin as distributed that was
> simply masked by the fact that the target directory exists on the machine(s)
> used to test Oxygen? I would have never noticed the problem if I had kept my
> 1.4.1 Toolkit around.
> Thanks,
> Eliot

More information about the oXygen-user mailing list