[oXygen-user] Variable names stops working

Adrian Buza
Thu Jul 7 07:27:18 CDT 2011


We've tested this with Ubuntu 11.04 but could not reproduce the problem 
you describe.

Please copy the attached 'log4j.properties' file to the Oxygen 
installation directory and restart Oxygen. Then reproduce the problem 
and close Oxygen. You will find a directory named 'oxygenLog' in your 
Desktop directory and inside it the generated log files(oxygen.log.*). 
Please zip those files and send them to our support email address: 

The file 'log4j.properties' triggers the debug mode which decreases the 
application performance severely. At the end of the procedure please do 
not forget to remove this file from the Oxygen installation directory.


Adrian Buza
oXygen XML Editor and Author Support


Jostein Austvik Jacobsen wrote:
> I'm having some (really weird) trouble, and unfortunately I'm unable 
> to reproduce it on other computers, but here's a short pipeline:
> <?xml version="1.0" encoding="UTF-8"?>
> <p:pipeline xmlns:p="http://www.w3.org/ns/xproc" version="1.0">
>     <p:variable name="daisy-dir" select="'daisy-dir'"/>
>     <p:variable name="other-dir" select="'other-dir'"/>
>     <p:add-attribute match="/*" attribute-name="daisy-dir">
>         <p:with-option name="attribute-value" select="$daisy-dir"/>
>         <p:input port="source">
>             <p:inline>
>                 <doc/>
>             </p:inline>
>         </p:input>
>     </p:add-attribute>
>     <p:add-attribute match="/*" attribute-name="other-dir">
>         <p:with-option name="attribute-value" select="$other-dir"/>
>     </p:add-attribute>
> </p:pipeline>
> You'd expect to get:
> <doc daisy-dir="daisy-dir" other-dir="other-dir"/>
> But on my computer with <oXygen/> XML Editor 12.2, build 2011051714 on 
> Ubuntu 11.04, I get:
> <doc daisy-dir="" other-dir="other-dir"/>
> This only happens in oXygen on my Ubuntu though, not if I run calabash 
> from the command line in Ubuntu or oXygen in Windows; so I don't know 
> how to reproduce the problem on other computers.
> If I rename the variable from "daisy-dir" to something else, it 
> works. So for some reason, the oXygen installation is ignoring 
> variables that are called "daisy-dir" all of a sudden... I changed it 
> to "input-dir" and it worked for a while, but after a few minutes, 
> oXygen started ignoring variables with that name as well. Doing a 
> "find | xargs grep -i daisy 2>/dev/null" in the oxygen directory gives 
> no relevant hits, so I'm not sure how to debug this further... Is 
> there any logfiles I can provide?
> I have a hunch that it may have to do with variables and options 
> having the same name across files/steps (example below), and how 
> that's stored internally in either oxygen or calabash, but I'm really 
> not sure. I do this in the pipeline I'm trying to run, but when the 
> option name stops working - it stops working in all pipelines.
> <p:variable name="input-dir" select="'something'"/>
> ...
> <p:with-option name="input-dir" select="$input-dir"/>
> Regards
> Jostein
> ------------------------------------------------------------------------
> _______________________________________________
> oXygen-user mailing list
> http://www.oxygenxml.com/mailman/listinfo/oxygen-user

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: log4j.properties
Url: http://www.oxygenxml.com/pipermail/oxygen-user/attachments/20110707/f88892f4/attachment.pl 

More information about the oXygen-user mailing list