[oXygen-user] Variable names stops working

Jostein Austvik Jacobsen
Thu Jul 7 06:26:19 CDT 2011

I'm having some (really weird) trouble, and unfortunately I'm unable to
reproduce it on other computers, but here's a short pipeline:

<?xml version="1.0" encoding="UTF-8"?>
<p:pipeline xmlns:p="http://www.w3.org/ns/xproc" version="1.0">
    <p:variable name="daisy-dir" select="'daisy-dir'"/>
    <p:variable name="other-dir" select="'other-dir'"/>

    <p:add-attribute match="/*" attribute-name="daisy-dir">
        <p:with-option name="attribute-value" select="$daisy-dir"/>
        <p:input port="source">
    <p:add-attribute match="/*" attribute-name="other-dir">
        <p:with-option name="attribute-value" select="$other-dir"/>

You'd expect to get:
<doc daisy-dir="daisy-dir" other-dir="other-dir"/>

But on my computer with <oXygen/> XML Editor 12.2, build 2011051714 on
Ubuntu 11.04, I get:
<doc daisy-dir="" other-dir="other-dir"/>

This only happens in oXygen on my Ubuntu though, not if I run calabash from
the command line in Ubuntu or oXygen in Windows; so I don't know how to
reproduce the problem on other computers.

If I rename the variable from "daisy-dir" to something else, it works. So
for some reason, the oXygen installation is ignoring variables that are
called "daisy-dir" all of a sudden... I changed it to "input-dir" and it
worked for a while, but after a few minutes, oXygen started ignoring
variables with that name as well. Doing a "find | xargs grep -i daisy
2>/dev/null" in the oxygen directory gives no relevant hits, so I'm not sure
how to debug this further... Is there any logfiles I can provide?

I have a hunch that it may have to do with variables and options having the
same name across files/steps (example below), and how that's stored
internally in either oxygen or calabash, but I'm really not sure. I do this
in the pipeline I'm trying to run, but when the option name stops working -
it stops working in all pipelines.

<p:variable name="input-dir" select="'something'"/>
<p:with-option name="input-dir" select="$input-dir"/>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.oxygenxml.com/pipermail/oxygen-user/attachments/20110707/8b644441/attachment.html 

More information about the oXygen-user mailing list