[oXygen-user] Still having problems with XSD catalogs

Sorin Ristache
Thu Feb 23 04:41:19 CST 2006

Hi John,

I get no validation errors for your catalog. I think there is a problem 
in the catalog.xsd that you are using. I created a local catalog.xsd 
file with the grammar contained in the OASIS XML catalog specification:


I changed the xsi:schemaLocation attribute of your catalog file to point 
to my local catalog.xsd. I got no validation errors for catalog.xsd or 
your catalog file.

Best regards,

> Hi Sorin,
> Thanks for that information.  I think that I have done to my catalog.xml file
> what you suggested.  Here it is:
> <?xml version="1.0" encoding="UTF-8"?>
> <catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
> 	xsi:schemaLocation="urn:oasis:names:tc:entity:xmlns:xml:catalog
> file:///E:/downloads/ISO19139/2006-01-13/catalog.xsd">
> 	<system systemId="http://schemas.opengis.net/xlink/1.0.0/xlinks.xsd"
> uri="file:///E:/downloads/GML3.1/GML3.1.1/xlink/xlinks.xsd"/>
> 	<system
> systemId="http://schemas.opengis.net/gml/3.1.0/xlink/xlinks.xsd"
> uri="file:///E:/downloads/GML3.1/GML3.1.1/xlink/xlinks.xsd"/>
> 	<rewriteURI
> uriIdStartString="http://schemas.opengis.net/gml/3.1.1/base"
> rewritePrefix="file:///E:/downloads/GML3.1/GML3.1.1/base"/>
> </catalog>
> Did I get it right?  If so I still get the same error when I try to validate
> the catalog.xml document.
> I also get an error when I try to validate the catalog.xsd document.
> You help is greatly appreciated on this matter.
> Thanks.
> John

More information about the oXygen-user mailing list