Page 1 of 1

Eclipse 3.3 and Oxygen 7.2 crash when opening an XSLT file

Posted: Wed Aug 08, 2007 12:06 pm
by DavidPérez
More details here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=199220

Any ideas?
Thanks in advance.

Posted: Mon Aug 13, 2007 4:51 pm
by sorin_ristache
Hello,

The "Cannot initialize Drop" SWT error is caused by the drag and drop API changes introduced by Eclipse 3.3. oXygen 7.2 was released before Eclipse 3.3 so it does not support these changes. This is why you have to use the oXygen 8.2 plugin for Eclipse 3.3 which is the first version that supports the changs introduced by Eclipse 3.3.

The same problem was reported here (see the end of the thread).


Regards,
Sorin

PS: The person from the Eclipse team who tried to reproduce the bug (Duong) could not do that because he used an .xls file (probably an Excel stylesheet) instead of an .xsl one (an XSLT stylesheet).

Posted: Tue Aug 14, 2007 8:02 am
by DavidPérez
Thanks for the detailed explanation.

So, is a new license needed to overcome this problem?

sorin wrote:Hello,

The "Cannot initialize Drop" SWT error is caused by the drag and drop API changes introduced by Eclipse 3.3. oXygen 7.2 was released before Eclipse 3.3 so it does not support these changes. This is why you have to use the oXygen 8.2 plugin for Eclipse 3.3 which is the first version that supports the changs introduced by Eclipse 3.3.

The same problem was reported here (see the end of the thread).


Regards,
Sorin

PS: The person from the Eclipse team who tried to reproduce the bug (Duong) could not do that because he used an .xls file (probably an Excel stylesheet) instead of an .xsl one (an XSLT stylesheet).

Posted: Tue Aug 14, 2007 9:47 am
by sorin_ristache
Hello,

If you did not purchase the Maintenance Pack option with your version 7 license key then you have to purchase an upgrade to oXygen version 8. If you are not sure about what you purchased please contact us.


Regards,
Sorin