Page 1 of 1

Unable to open any .xsl or .xquery -files in Eclipse

Posted: Fri Jun 29, 2007 1:41 pm
by masuuni
I tried multiple distributions of Eclipse and different combinations of plugins I regularly use, and I found out, that only with fresh installation of basic Eclipse 3.2.2 SDK, Oxygen plugin will work as it is supposed to. However, certain plugins require plugins, which require plugins, which require Eclipse 3.3 and with that version of Eclipse, Oxygen plugin will not work. Atleast not with .xsl and .xquery -files. I tried version 3.3RC4 of Eclipse.

Normally I use PDT Project's all-in-one distribution. Neither 0.7 nor 1.0 version of it creates suitable base for Oxygen plugin install.

Well, there's always standalone version, but I kind of like using Eclipse, so it would be nice, if I could somehow overcome this problem.

--

There might other problems, but so far I've only tried opening of certain type of files. I can't open any .xsl or .xquery files. Not even ones created using New -> Stylesheet (XSL) File or New -> XQuery File.

Error messages for both XSL and XQuery files:
- Internal Error: An SWT error has occurred
- Unhandled event loop exception, Reason: Cannot initialize Drop

Oxygen messages with XSL files:
[07:49:00] - Stylesheet Error Scanner - start scanning file:/...untitled3.xsl using engine Saxon6.5.5
[07:49:00] - Found 0 problem(s)

Oxygen messages with XQuery files:
[07:52:13] - XQuery Error Scanner - start scanning file:/untitled2.xquery using engine Saxon8B XQuery
[07:52:14] - Found 1 problem(s)

Problem message with XQuery files:
[Saxon8B XQuery] XQuery syntax error in ##: Unexpected token "<eof>" in path expression test untitled2.xquery line 1

Posted: Fri Jun 29, 2007 3:12 pm
by sorin_ristache
Hello,

You have to use the oXygen plugin for Eclipse 3.3, not the plugin for Eclipse 3.2. The plugin for Eclipse 3.2 does not work in Eclipse 3.3 RC4 and it will not work in the final Eclipse 3.3. In Eclipse 3.3 RC4 with the oXygen plugin for Eclipse 3.3 I can open and edit .xsl files and .xquery files without problems. oXygen supports only Eclipse SDK. Other platforms that do not include the plugins required by the oXygen plugin are not supported.


Regards,
Sorin

Posted: Fri Jun 29, 2007 4:28 pm
by masuuni
Thank you. That's exactly where the problem was. Issue is now fully solved. I guess I just somehow forgot the existence of 3.3 version of Oxygen plugin, while being too busy trying other solutions. :D

Posted: Fri Jun 29, 2007 4:40 pm
by kingargyle
Does it actually require the SDK, or just the JDT be available? If so, then you can download PDT 0.7 or 1.0, and then just add the JDT as an eclipse plugin.

If possible, I would suggest trying to eliminate the need for the SDK, as it adds uncessary overhead unless it is absolutely needed. You could have a nice lean implemenation with just the platform eclipse install.

Posted: Mon Jul 02, 2007 12:19 pm
by sorin_ristache
Hello,

It does not require the Eclipse SDK. You can use also the Eclipse platform runtime for running the oXygen plugin.


Regards,
Sorin