[oXygen-user] 10.1 takes a step backward?

Sorin Ristache
Mon Mar 9 05:32:45 CDT 2009


The buttons used for entering a file path in a dialog (Browse for local 
file, Browse for remote file, Browse for archive file) are not focusable 
anymore. We will make them focusable again.


Syd Bauman wrote:
> One action I perform reasonably frequently is Associate Schema,
> although it's usually via the New XML Document rather than explicitly
> associating a schema to an already existing XML document. Either way,
> in previous versions of oXygen I would perform this entirely from the
> keyboard. Something like:
> * cmd-N                       > new dialog
> * XML Document selected       > defaulted from last time
> * enter                       > gets "Create an XML document" dialog
> * Use DTD or Schema checked   > defaulted from last time
> * tab                         > moves me to set of schema language tabs
> * R-cursor R-cursor           > selects Relax NG
> * tab tab                     > selected "browse local" folder icon [X]
> * space                       > gets open dialog box
> * [navigate to schema]        > use normal Mac OS X keystrokes
> * return                      > syntax button automatically set from extension
> * return                      > done!
> But note the [X]. Here, in oXygen 10.0 (and earlier versions, but I
> don't know how far back), there was no visual indication that I had
> selected the button with the normal folder icon that means "Browse
> for local file" (the leftmost of the 2 or 3 folder icons for browsing
> local, remote, or archive), but it worked. Now, in 10.1, tabbing in
> this dialog box skips right over the browse icons! I've tried all
> sorts of key combinations (ctl-tab, opt-tab, cursor keys, cursor keys
> w/ modifiers, etc.), but cannot seem to select that button without
> using the pointer.

More information about the oXygen-user mailing list