Git Staging won't accept my SSH passphrase

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
pdenchfield
Posts: 1
Joined: Wed May 15, 2019 9:18 pm

Git Staging won't accept my SSH passphrase

Post by pdenchfield » Wed May 15, 2019 9:23 pm

TortoiseGit accepts my passphrase but the Git Staging add-on in Oxygen Editor does not. Any ideas?

Thanks,
Pamela

alex_jitianu
Posts: 669
Joined: Wed Nov 16, 2005 11:11 am

Re: Git Staging won't accept my SSH passphrase

Post by alex_jitianu » Thu May 16, 2019 9:11 am

Hello,

I think this happens because the add-on doesn't recognize the SSH key. There are a couple of things I want to mention about the keys:

1. ED25519 keys - The Git plugin is based on the JGit library which, unfortunately, doesn't support the ED25519 SSH keys. If you are trying to use one, perhaps switch to an RSA [1] key.

2. RSA keys - Again, the JGit library has a problem loading RSA keys that are in the newer OpenSSH format. You can verify if it's in that format by looking at the private key (found in a file named like ~/.ssh/id_rsa) and see if it starts with:

-----BEGIN OPENSSH PRIVATE KEY-----

The Gitlab documentation for example advises to generate an RSA SSH key in the OpenSSH format [1] (see the -o parameter):

ssh-keygen -o -t rsa -b 4096 -C "email@example.com"

But what you should do is to generate it without the -o parameter:

ssh-keygen -t rsa -b 4096 -C "email@example.com"

Another aspect to consider is that starting with version 7.8, ssh-keygen uses the OpenSSH format by default. If you are using that version or a newer version, you can make it use the previously-used PEM format [2] using the -m parameter:

ssh-keygen -m -t rsa -b 4096 -C "email@example.com"

[1] https://gitlab.com/help/ssh/README#rsa-ssh-keys
[2] http://man.openbsd.org/OpenBSD-current/ ... gen.1#NAME

Please let me know if the keys were the problem.

Best regards,
Alex

Post Reply