Responsive top nav not working on Windows computers

misti
Posts: 13

Responsive top nav not working on Windows computers

Thu May 17, 2018 6:35 pm

Hello-

We upgraded to Oxygen 20 and the webhelp responsive output is putting out help systems where the top nav doesn't seem to be "clickable" on Windows machines. It works perfectly on Mac, but people in our support org with Windows laptops are able to mouse over the top nav but nothing happens when they click on an item. (The correct URL is being displayed in the preview down below and the pointer changes like they're on a link, but nothing happens on click.)

This is happening at both nav levels on all browsers. It is also happening when they try to use the Oxygen XML 20 help system, so it is not something specific to only our builds. We just released our 20-based help yesterday; the top nav was working without issue in our Oxygen 19 generate responsive help.

Thanks,
Misti
Costin
Posts: 333

Re: Responsive top nav not working on Windows computers

Fri May 18, 2018 11:48 am

Hi misti,

We are not aware of such issues.
webhelp responsive output is putting out help systems where the top nav doesn't seem to be "clickable" on Windows machines.

Could you please clarify what you refer to by "the top nav"? Is it the top menu of your documentation?

You state that you encountered this issue also on the Oxygen XML 20 help system, so - in case you refer to the publicly available oXygen User-Guide, which is also a WebHelp Responsive output - I just double checked but clicking any item from the top menu works on any browser I tried (I am using IE11 v11.48, Firefox Quantum v60.0 and Chrome v66.0).
What internet browsers are you using and which specific version?

Or maybe are you referring to the WebHelp Responsive output obtain by running the out-of-the-box DITA Map WebHelp Responsive transformation scenario applied on one of the sample projects in oXygen? If it's this second case, can you make sure you are using the latest version and build of oXygen? The latest maintenance build available in the Download section from our website is 2018042410. You can see which build are you using in the oXygen menu Help > About.
This is happening at both nav levels on all browsers.
In order to investigate, can you please provide a screenshot depicting some example menu links for which you reproduce the reported issue? You can use our official support email: support@oxygenxml.com to send the screenshot.

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support
misti
Posts: 13

Re: Responsive top nav not working on Windows computers

Fri May 18, 2018 9:43 pm

I am talking about the publicly available Oxygen webhelp. We have two separate Windows 10 users (on different Lenovo laptops) who are having this happen in all browsers (Chrome, Safari, Firefox, IE). They can mouse over the top nav (in our documentation and in your documentation) and have the options appear, but when they click on a nav item nothing happens. It's like the click isn't being recognized. For example, they'll mouse over "Working With Documents" but when they try to click Simple Text Editor, nothing happens.

When I tested with a Dell laptop on Windows 10, it worked for me, so there's definitely an inconsistency as this not working for some users but working for others.
Costin
Posts: 333

Re: Responsive top nav not working on Windows computers

Mon May 21, 2018 11:58 am

Hi misti,

You state that this also reproduces on Safari, but Safari is a Mac OS specific browser, but also state that the two Lenovo laptops are running Windows 10. Could you please clarify?

As I previously specified, we are not aware of such issues, so this seems related to the specific environments of the two users.
In order to try reproduce this, could you please let us know which specific versions of the internet browsers are the end-users working with when this occurs?

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support
misti
Posts: 13

Re: Responsive top nav not working on Windows computers

Mon May 21, 2018 4:11 pm

Sorry, I misspoke when I said Safari. The laptops are running Windows 10 and it is the most recent versions of the browsers.
Costin
Posts: 333

Re: Responsive top nav not working on Windows computers

Tue May 22, 2018 11:29 am

Hi misti,

Because we could not reproduce this issue and it seems to be specific to a peculiar system configuration (hardware+software), we need to investigate this over time and see if we can reproduce the issue.
That's why we already have logged this in our internal issues tracking system so it will be further analyzed.
I'm afraid there is no solution we can offer for the time being, but we will update this thread if we reach to a conclusion and find a solution.

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support
misti
Posts: 13

Re: Responsive top nav not working on Windows computers

Tue May 22, 2018 5:37 pm

That sounds fair. I will let you know if we have any other reports of issues or figure out why it isn't working for these particular customer support members.

Thanks,
Misti

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 1 guest