Page 1 of 1

Run Dita OT 1.4.3 in Oxygen 12.1 follow-up

Posted: Sun Apr 10, 2011 11:55 am
by anderszvensson

This is a follow-up question to an issue I never actually got resolved:

I need to be able to run DITA OT 1.4.3 for a client, and also Antenna House as the pdf renderer. So I'm trying to get it to work according to the instructions in the previous post answer. But I'm getting this error:

C:\projects\itt_1_4_3\DITA-OT1.4.3\build.xml:59: The following error occurred while executing this line:
C:\projects\itt_1_4_3\DITA-OT1.4.3\build_preprocess.xml:25: java.lang.NoSuchFieldError: catalogEntries

I tried with both the default resolver, since this wasn't mentioned as one of the jar files to replace. And I also tried replacing it with the resolver from the custom DITA OT folder I'm using.

None of these worked. So what is this error message, and how can I get around it?



Re: Run Dita OT 1.4.3 in Oxygen 12.1 follow-up

Posted: Mon Apr 11, 2011 3:23 pm
by Radu
Hi Anders,

Please give us the entire Oxygen console output after the transformation has ended.

From what I remember you are using an older version of Oxygen (10.3) which does not have support at scenario level for defining precisely all libraries which will be used by ANT for transformation.

What probably happens is that Oxygen has patches (in the "oxygen.jar" library) for the "resolver.jar" library which do not match your used catalog resolver.

In newer versions of Oxygen you can have full control over all libraries sent to the DITA OT ANT process.
The first extensions in the list (added by default) contain Oxygen patches. For example you can move UP the custom resolver.jar library you are using so that it is located before our patch libraries.