Page 1 of 1

Catalogs not working for XProc?

Posted: Thu Dec 02, 2010 6:39 pm
by Zearin
My (lack of) Experience with XML Catalogs
I have never (knowingly) used Catalogs before. I have a basic understanding of their purpose, but I've always explicitly validated using <?oxygen ?> instructions for schemas or Oxygen's built-in validation.

The Problem
I have an XProc pipeline that is sending an http-request. The site is It is written in XHTML 1.1 and includes a Doctype. When I make the request, it appears that something is looking up that Doctype and using it to validate the http-response. During that process I am getting errors about certain files not being found.

Note: Strangely enough the same pipeline had been working a couple of weeks prior. I have been told that this may have begun because repeated requests to the W3C will get you banned for a period of time. I wasn't aware this validation had been happening at that time, so I made several http-requests as I was tweaking and refining my pipeline.

The Error
[quote]SystemID: /Users/amrogers/Developer/Projects/oXygen_workspace/edu.umd/terpconnect/model/documents/201008/INFM298I/Final Project/xproc.xpl
Engine name: Calabash XProc
Severity: error
Description: net.sf.saxon.s9api.SaxonApiException: org.apache.commons.httpclient.HttpException: 404 Not Found for: 404 Not Found for:

Attempts so far
I have tried to set the XHTML 1.1 Catalog in Preferences→XML→XML Catalog. I have also tried setting the same Catalogs in Preferences→Document Type Association→XHTML→Catalogs.

Out of desperation I have tried both the DTD and schema Catalogs.

Someone on the XProc mailing list even said that Oxygen automatically passes its catalog info to XProc.

But I'm still getting the error. :(

Help me XML-Kenobi…you're my only hope…
This pipeline is part of a class project and I'm beginning to become quite worried. If I could just tell the pipeline to use local validation that would solve everything! But I am completely baffled about how to do that.

Can anyone help me?

Re: Catalogs not working for XProc?

Posted: Fri Dec 03, 2010 6:04 pm
by sorin_ristache

There was a similar discussion thread on the Oxygen-user list. You may want to check if you have the same problem.

All the XML catalogs specified in Preferences -> XML -> XML Catalog are passed to the XProc processor (Calabash). It seems you did not set the URIs correctly in your XML catalog.

Fetching a DTD module by HTTP is required by the XML parser to check if the XML document that refers (indirectly) to that DTD module is well-formed (for example resolving DTD entity references). It does not have to be used for validation.

If you double checked that the file paths are specified correctly in the XML catalog and the system ID or public ID are set correctly in the XML files you may send us sample files for reproducing the error: an XProc pipeline and an XML catalog file.


Re: Catalogs not working for XProc?

Posted: Tue Dec 07, 2010 12:49 am
by Zearin
Still getting the error. Where do I send the files?

Re: Catalogs not working for XProc?

Posted: Tue Dec 07, 2010 12:59 am
by george

Best Regards,