Page 1 of 1

XSLT timeout

Posted: Sat Feb 27, 2016 8:55 pm
by gpm2a
Using Saxon EE for XSLT transformation of a very large document, where each "record" in the XML is output to a file on disk, the XSLT process fails with a timeout error. Is there a way to increase the time limit?

Re: XSLT timeout

Posted: Mon Feb 29, 2016 11:27 am
by adrian

Could you please provide the full error message?
Are all the resources involved in the transformation in the local file system, or are there some remote files involved?

Timeout errors usually appear when a remote resource is unavailable, so it may not have anything to do with the size of the file, but its availability.
If it's indeed a remote resource timeout, you can adjust the timeout value in Options > Preferences, Network Connection Settings > HTTP(S)/WebDAV, "Read timout (seconds)". Avoid using more than 60, as it can increase delays when there is a real problem.


Re: XSLT timeout

Posted: Sat Mar 05, 2016 11:26 pm
by gpm2a

Thank you very much for the suggestions. Yes, the large XML document I was processing was located on a network drive. As you suggested, I moved the whole process to local disk. But I didn't actually try this again in oXygen. Instead I used Saxon at the command line, which worked fine. Doing so allowed me to continue using oXygen while the transformation was running, which took about 19 hours.