Page 1 of 1

Webhelp Responsive: prevent caching

Posted: Thu Mar 26, 2020 8:58 pm
by mdslup
Using Dita with Webhelp responsive.

I update my documentation frequently. Many times, I make a change and the users do not see it until after they refresh the page.

Is there anything I can do about this?

I noticed this article: ... hl=caching

but this article is about Docbook and webhelp classic.

Is there a similar topic about DITA and webhelp responsive?

Re: Webhelp Responsive: prevent caching

Posted: Fri Mar 27, 2020 1:03 pm
by Costin

If you refer that the end-users need to refresh the web browser page to see the latest revision of the WebHelp output (using the F5 shortcut, or the refresh action), this is intended behavior and that's how it works for each page.

Even in the section from the WebHelp Classic User-Guide that you stumbled upon, reads:
upon re-loading it in a Web browser on the client side


Re: Webhelp Responsive: prevent caching

Posted: Fri Mar 27, 2020 7:45 pm
by mdslup
Can you explain why that is the intended behavior? It seems like it should not be. I do not want any situation where my users go to a webpage that I have updated, but that shows the old version. Am I missing something here?

Re: Webhelp Responsive: prevent caching

Posted: Tue Mar 31, 2020 1:49 pm
by bogdan_cercelaru

As explained in the topic that you've indicated, you can use the following meta information to disable browser caching.

Code: Select all

<meta http-equiv="Pragma" content="no-cache" />
<meta http-equiv="Expires" content="-1" />
but you have to add them using the

Code: Select all

parameter from the transformation scenario (instead of editing other WebHelp plugin files indicated in the topic).
Please note that even if you are using the <meta/> elements, any web proxies between the site/server and the user/browser will completely ignore them. You should always use a real HTTP header for headers such as Cache-Control and Pragma.


Re: Webhelp Responsive: prevent caching

Posted: Thu Apr 02, 2020 1:32 am
by mdslup
OK, thanks very much Bogdan. Stay safe.