Page 1 of 1

Review Pane "Next" Button Won't Jump to Next Topic

Posted: Thu Sep 12, 2019 7:29 am
by jmorales
Hi, Using XML Author 21.0, build 2019022207, I have a ditamap open and some of the topics have revisions in them. I was hoping to use the down arrow "next" button in the Review panel to jump ahead to each topic that contains revisions. When I first tried it, it asked if I wanted to jump to the next topic, but when I said yes, it just ignored me and sat there in the current topic. So the next time it asked, I foolishly clicked the box saying to not ask the question again. Now it doesn't even ask me if I want to jump to the next topic. Is there some option I can change that will make the next button jump to the next topic in the ditamap that has revisions? If not, is there some other way to locate all the topics in a ditamap that have revisions?


Re: Review Pane "Next" Button Won't Jump to Next Topic

Posted: Thu Sep 12, 2019 10:02 am
by sorin_carbunaru

Using <oXygen/> XML Editor 21.0, build 2019030604, which I had installed on my PC, I was successful in navigating through the topics containing revisions (comments in my case). I tried with the Flowers sample from oXygen opened in the DITA Maps Manager. I then tried with <oXygen/> XML Author 21.0, build 2019040204, and again everything went just fine.

To decide what happens when you press the "Next button", see the "When the last/first item is reached while navigating reviews:" option from the DITA preferences page ( ... view-items).

Best wishes,
Sorin Carbunaru
oXygen XML

Re: Review Pane "Next" Button Won't Jump to Next Topic

Posted: Thu Sep 12, 2019 9:22 pm
by jmorales
Thanks Sorin. I still see the problem, regardless of how the DITA preference is configured. I have submitted a technical support issue with an embedded link to a screencast where you can see a recording of the behavior. (I wasn't sure if we're allowed to include links in forum entries.)

Re: Review Pane "Next" Button Won't Jump to Next Topic

Posted: Mon Sep 16, 2019 10:56 am
by sorin_carbunaru
Hi Joseph,

Could you please try the following?
1. Make sure the project that contains the DITA map you are editing is opened in the Project view.
2. Go to Window > Show view > Open/Find Resources.
3. Invoke the Clear index action (see the cogwheel next to the filter panel).
4. Invoke the Reindex action (see the link in the results area).
5. Try navigating through the revisions again.

If it still doesn't work, please create a "" file in oXygen's installation directory (on the same level as oxygen.exe) with the following content:

Code: Select all

log4j.rootCategory=info, R2

log4j.appender.R2.layout.ConversionPattern=%r %p [ %t ] %c - %m%n
After creating this file, please try again your scenario. The created file will not fix the problem in any way, but instead it will create an "oxygenLog" folder on your Desktop, after you restart oXygen, reproduce the problem and close the application. After you do all of these, please archive the log folder and send it to for further investigations.

All the best,
Sorin C.