Page 1 of 1

oxy_audio error in Author page

Posted: Thu Apr 06, 2017 3:45 pm
by Johann
Hi everyone,

I'm using the 18.1.0.0 SDK version and when I try to use :

Code: Select all

multimedia {
content: oxy_audio(href, url(../test.MP3), width, 400px);
}


I get this error :

Code: Select all

java.lang.NoClassDefFoundError: ro/sync/jfx/JFXException
   at ro.sync.ecss.component.editor.c.e.c(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.component.editor.c.b.ed(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.component.editor.c.b.id(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.x.qe(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.x.<init>(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.jb.y(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.eb.li(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.eb.<init>(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.hm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.em(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.am(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.li(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.sb.li(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.component.o.relayout(Unknown Source) ~[oxygen-18.1.0.0.jar:na]...


Any idea about this issue ?

Thanks,

Johann

Re: oxy_audio error in Author page

Posted: Thu Apr 06, 2017 4:55 pm
by Radu
Hi Johann,

You are missing a Java library called oxygen-jfx-components.jar. I think you could pick it up from a standalone Oxygen XML Editor installation (from the "lib" folder). I will also discuss with my colleague who knows more about how the SDK was mavenized, see if we exposed this library via Maven or not.

Regards,
Radu

Re: oxy_audio error in Author page

Posted: Fri Apr 07, 2017 9:26 am
by Radu
Hi,

It seems that indeed we did not expose this extra library via Maven so right now you will have to manually add it as a dependency. I added an internal issue to also provide this library via Maven.

Regards,
Radu

Re: oxy_audio error in Author page

Posted: Fri Apr 07, 2017 9:37 am
by Johann
Hi Radu,

I manually added the dependency and it works.

Thank you,

Johann

Re: oxy_audio error in Author page

Posted: Fri Apr 07, 2017 11:02 am
by Johann
It works but I don't know if I have something wrong in my environment because the audio player is truncated both in the Oxygen XML software and in the Oxygen component (18.1 version).

This is what I see when opening C:\Program Files\Oxygen XML Editor 18\samples\form -controls\about\form-controls.xml :

Image

Any idea ?

Thanks,

Johann

Re: oxy_audio error in Author page

Posted: Mon Apr 10, 2017 2:39 pm
by alex_jitianu
Hi,

Do you happen to have a retina/ HiDpi screen?
I will send you an email with a modified version of oxygen-jfx-components.jar that contains a possible fix to this issue. You can replace the exisitng one inside {oxygenInstallDir}/lib and test again.

Best regards,
Alex

Re: oxy_audio error in Author page

Posted: Wed Apr 12, 2017 11:05 am
by Johann
Hello Alex,

I do not have a specific screen... I tried to replace the jar file by the one you sent by email but it does not change anything.
Am I the only one to have this behaviour ?

Johann

Re: oxy_audio error in Author page

Posted: Wed Apr 12, 2017 12:02 pm
by alex_jitianu
Hi Johann,

We tested on multiple stations and operating systems but we didn't reproduce this behavior. You are also the only one that reported this situation so far. Can you test an Oxygen version 19 and see if the same behavior happens when opening samples\form -controls\about\form-controls.xml? Perhaps we've solved it without even knowing...

Best regards,
Alex

Re: oxy_audio error in Author page

Posted: Fri Apr 14, 2017 4:21 pm
by Johann
Hi Alex,

I just tried in Oxygen version 19 and I get the same error when I open samples\form -controls\about\form-controls.xml...

Johann

Re: oxy_audio error in Author page

Posted: Tue Apr 18, 2017 11:38 am
by alex_jitianu
Hi Johann,

Do you have a custom DPI (Dots per Inch) size setting? Perhaps it will also help if you send us more information about your system. The fastest way to do that is to go inside Oxygen to Help->Report problem... and just send us the report.

Best regards,
Alex