Page 1 of 1

Non breaking space

Posted: Thu Jan 24, 2019 8:34 am
by Vidhya
Is there a way to insert a non breaking space in the editor?
When I am typing in something like 2 cm, I do not want 2 on one line and cm in the next.

Re: Non breaking space

Posted: Thu Jan 24, 2019 10:00 pm
by Costin

You could add it either in the Text editing mode, using the " " character code, or in the Author (visual) editing mode, using the context menu Insert action (right click somewhere in the document, where you need the non-breaking-space to be inserted, then choose Insert > Insert entity and type nbsp > click Insert.

There are also space preserve options available in the oXygen menu Options > Preferences > Editor > Format > XML.


Re: Non breaking space

Posted: Fri Jan 25, 2019 4:28 am
by Vidhya
That is really helpful. Thank you!

Re: Non breaking space

Posted: Fri Mar 12, 2021 12:02 am
by Contra8
Sorry to jump on this train late but how can I keep a   from being converted when the XML file is saved to the eXist database?

All our   are converted to a Unicode U+00A0 when we close an XML file and re-open it. This makes it very hard for the editing persons to recognize the non-breaking spaces from the simple spaces.

Is there a magic thing we can configure in our oXygen? Or maybe it is an issue with the eXist database?

Re: Non breaking space

Posted: Fri Mar 12, 2021 8:53 am
by Radu

This is most probably a problem related to how the Exist database might change the XML content saved by Oxygen to it.
I've seen this problem discussed multiple times on the Exist users list: ... sg27028178

If you want you can also register on the Exist users list and ask around.