Display inherited types

This should cover W3C XML Schema, Relax NG and DTD related problems.
susi
Posts: 4
Joined: Tue Nov 20, 2012 12:26 pm

Display inherited types

Post by susi » Thu Nov 22, 2012 5:10 pm

Hello,
It seems that something changed with my current oXygen (14.1), but I don't find the right "Option" to revert to the used behaviour. :-(

When displaying an XML Schema changing from "Text" to "Design" the inherited types ("extension base") were shown in a violett rectangle with its sub-elements and attributes. But now I only get the "direct sub-elements" without any possibility to expand the "type's rectangle".
What "Option" do I have to change in order to display the types again?

Thanks for any hints.
Kind regards...
Susi

Costin
Posts: 543
Joined: Mon Dec 05, 2011 6:04 pm

Re: Display inherited types

Post by Costin » Thu Nov 22, 2012 6:31 pm

Hello,

I have just tested this behavior and I could not reproduce it on our side.
However, you should first go into oxygen menu to Options > Preferences > Editor / Edit modes / Schema Design / Properties and under "Complex Type", check if you have "Base Type" set to appear in the Design mode.
More precisely, you should check if you have the default settings.

In case this issue is still persistent and if you do not recall having any customizations, you should try to Restore Defaults, using the button at the bottom of the Schema design Properties window and see if that solves anything.

Let me know if you encounter further issues.

Regards,
Costin
Costin Sandoi
oXygen XML Editor and Author Support

susi
Posts: 4
Joined: Tue Nov 20, 2012 12:26 pm

Re: Display inherited types

Post by susi » Thu Nov 22, 2012 7:53 pm

Hello Costin,
Costin wrote:I have just tested this behavior and I could not reproduce it on our side.
What a pity.
Costin wrote:However, you should first go into oxygen menu to Options > Preferences > Editor / Edit modes / Schema Design / Properties and under "Complex Type", check if you have "Base Type" set to appear in the Design mode.
More precisely, you should check if you have the default settings.
In the meantime I also found this options, and played a bit around, resetting defaults, enabling all ... but nothing changed. :?

I generated a nice HTML-Documentation with oXygen last year:
http://schemas.railml.org/2011/railML-2 ... astructure
But currently I only see the five "direct sub-elements" of the element 'rail:infrastructure' in my oXygen-Editor?
You may download these files and have a look. Maybe you can reproduce the behaviour with exactly the same XML schema:
http://schemas.railml.org/versions/railML-v2.1.zip

I would be happy if you may reproduce the situation and give any further hints.

Kind regards...
Susi

ionela
Posts: 256
Joined: Mon Dec 05, 2011 6:08 pm

Re: Display inherited types

Post by ionela » Thu Nov 22, 2012 11:20 pm

Hi Susi,

We've investigated this issue with your files, but unfortunately we still cannot reproduce it on our side.
Could you please please send us a screen-shot with your XML Schema in Oxygen 14.1 design mode?
You can send it to our support email address: support AT oxygenxml DOT com

Regards,
Ionela
Ionela Istodor
oXygen XML Editor and Author Support

adrian
Posts: 2514
Joined: Tue May 17, 2005 4:01 pm

Re: Display inherited types

Post by adrian » Wed Dec 05, 2012 1:26 pm

Hi,

In case anyone else encounters this, this turned out to be a bug triggered by the option Process namespaces through URI mappings for XML Schema from Options > Preferences, XML > XML Catalog. This happens if a main schema has an include and their common namespace is resolved through an XML catalog to the main schema (via the option mentioned above). The problem is that the included schema (same namespace) is also resolved through the catalog to the main schema and this triggers the problem.

We will resolve this problem in the next minor version of Oxygen. This thread will be notified when it becomes available.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

dnlsur
Posts: 1
Joined: Thu May 22, 2014 1:25 am

Re: Display inherited types

Post by dnlsur » Thu May 22, 2014 1:33 am

Hi,

I found this problem in version 15.2. Was it fixed ?

Thanks,
Daniel.

adrian
Posts: 2514
Joined: Tue May 17, 2005 4:01 pm

Re: Display inherited types

Post by adrian » Thu May 22, 2014 11:44 am

Hi,

The problem reported in this topic has been fixed since v14.2. I must apologize for not notifying of this.

I can't reproduce this problem in v15.2. If possible, please send sample files and a description of the problem to our support email address: support@oxygenxml.com

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

adrian
Posts: 2514
Joined: Tue May 17, 2005 4:01 pm

Re: Display inherited types

Post by adrian » Wed May 28, 2014 3:06 pm

Hi Daniel,

Do you have any feedback on this issue?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply