Marklogic connection

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
cmcenearney
Posts: 6

Marklogic connection

Thu Apr 19, 2012 9:48 pm

Hi,

Just wondering if anyone can help with this. I am trying to set up a Marklogic data source using these docs

http://www.oxygenxml.com/doc/ug-oxygen/ ... ource.html

http://www.oxygenxml.com/MarkLogic_support.html

They explain that you need xcc.jar, xdbc.jar. and xdmp.jar driver files. I can only find xcc.jar, which I have installed.

When I open the connection Oxygen says the server failed to respond with a valid HTTP response. I'm not a developer and only have experience querying our db through cq, so I can't easily troubleshoot from the server end...

Many thanks in advance,
Colin
adrian
Posts: 2445

Re: Marklogic connection

Fri Apr 20, 2012 11:57 am

Hi,

xcc.jar, xdbc.jar. and xdmp.jar were required for MarkLogic 3.2.
For MarkLogic 4.0 and later there is only the XCC jar(e.g. marklogic-xcc-4.x.x.jar).

Regarding the error you are experiencing, check if the MarkLogic connection is correctly configured as described here:
http://www.oxygenxml.com/doc/ug-editor/ ... ction.html

Note that the MarkLogic server has three types (at least) of application servers that can be created and managed from the server management and administration page: HTTP, XDBC and WebDAV

For the XDBC host and port in the Oxygen connection make sure you use the port of an XDBC application server(not HTTP server).
For the WebDAV URL make sure you are using the URL of a WebDAV application server. e.g. http://hostname:port

Let us know if the problem persists.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 0 guests