Author mode - Learn word

<oXygen/> general issues.
honyk
Posts: 168
Joined: Wed Apr 29, 2009 4:55 pm

Author mode - Learn word

Post by honyk » Thu Mar 25, 2010 4:42 pm

Hello,

when a Default language for the spell check is set to English, the option 'Obey xml:lang and lang' is checked and in the DocBook document this attribute is set to "en", I am still getting error message when a new word is added to the custom dictionary via Learn word: Errorno language selected.

If the 'Obey' option is deselected, it works properly. I suspect Oxygen that it requires a different string in the lang attribute. I've tried en-GB and en-US, what has slightly changed spell check results, but Learning also fails (tested with the word 'Versioned').

What is strange I cannot reproduce this problem on another computer with the same settings (and version 11.2).

Any advice? Thanks in advance.

Regards,
Jan

Radu
Posts: 6708
Joined: Fri Jul 09, 2004 5:18 pm

Re: Author mode - Learn word

Post by Radu » Thu Mar 25, 2010 5:00 pm

Hi Jan,

First for the small issue:
The "en" xml:lang usually is checked with a combination of both the US and GB dictionaries so that is why there are differences.

And now for the big issue:
I cannot reproduce it either, can you zip and send us the entire Oxygen preferences directory?
Depending on the OS it should be in a location like:

Windows XP - [user-home-folder]/Application Data/com.oxygenxml
Windows Vista/7 - [user-home-folder]/AppData/Roaming/com.oxygenxml
Mac OS X - [user-home-folder]/Library/Preferences/com.oxygenxml

The directory should contain among others a file named oxyOptionsSa11.2.xml.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply