startup errors -- oXygen 2.0/Java 1.4.1/Mac OS X 10.2.4

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
jpkang
Posts: 11
Location: Princeton, NJ

startup errors -- oXygen 2.0/Java 1.4.1/Mac OS X 10.2.4

Thu Apr 03, 2003 5:53 am

I can't get oXygen to finish loading--only the application menu appears and nothing else in the menubar. Files that are dragged and dropped on the application icon do not open. I tried deleting all the com.oxygen.* preference files, with no effect. I've replicated this on a similarly configured PowerBook G4 and iMac G4.

Here's some pertinent info:

%java -version
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1_01-39)
Java HotSpot(TM) Client VM (build 1.4.1_01-14, mixed mode)

console.log:
2003-04-02 21:38:55.839 JavaApplicationStub[2165] Warning: Font LucidaSans-TypewriterBold claims fixed-pitch with 0 max advance!
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at ro.sync.exml.Oxygen.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at apple.launcher.LaunchRunner.run(LaunchRunner.java:88)
at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Caused by: java.lang.NullPointerException
at ro.sync.ui.b.b1(Unknown Source)
at ro.sync.ui.b.b4(Unknown Source)
at ro.sync.ui.b.<init>(Unknown Source)
at ro.sync.ui.b.b2(Unknown Source)
at ro.sync.exml.b.c.for(Unknown Source)
at ro.sync.e.j.a(Unknown Source)
at ro.sync.exml.b.r.bn(Unknown Source)
at ro.sync.e.d.bo(Unknown Source)
at ro.sync.e.d.<init>(Unknown Source)
at ro.sync.exml.b.r.<init>(Unknown Source)
at ro.sync.exml.b.r.bq(Unknown Source)
at ro.sync.exml.MainFrame.<init>(Unknown Source)
at ro.sync.exml.MainFrame.<init>(Unknown Source)
at ro.sync.exml.Launcher.main(Unknown Source)
... 12 more
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at ro.sync.exml.Oxygen.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at apple.launcher.LaunchRunner.run(LaunchRunner.java:88)
at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Caused by: java.lang.NullPointerException
at ro.sync.ui.b.b1(Unknown Source)
at ro.sync.ui.b.b4(Unknown Source)
at ro.sync.ui.b.<init>(Unknown Source)
at ro.sync.ui.b.b2(Unknown Source)
at ro.sync.exml.b.c.for(Unknown Source)
at ro.sync.e.j.a(Unknown Source)
at ro.sync.exml.b.r.bn(Unknown Source)
at ro.sync.e.d.bo(Unknown Source)
at ro.sync.e.d.<init>(Unknown Source)
at ro.sync.exml.b.r.<init>(Unknown Source)
at ro.sync.exml.b.r.bq(Unknown Source)
at ro.sync.exml.MainFrame.<init>(Unknown Source)
at ro.sync.exml.MainFrame.<init>(Unknown Source)
at ro.sync.exml.Launcher.main(Unknown Source)
... 12 more
Dan
Posts: 309

Thu Apr 03, 2003 9:31 am

Hello,

There are several problems on the new Java 1.4.1 for Mac OS X platform when querying the installed fonts. (We did not detect a pattern for reproducing the problem). There is a solution for making the editor avoid calling the buggy API and we will include it in the next release. As an imediate solution, please use the Java version 1.3.1, as it is explained here: http://www.oxygenxml.com/forum/viewtopic.php?t=38
george
Site Admin
Posts: 2100

Thu Apr 03, 2003 2:40 pm

Hi

If you look at the http://www.oxygenxml.com/forum/viewtopic.php?t=29 topic you will see that I was complaining about a NPE when starting oXygen on 1.4.1. We managed to solve this calling a different funtion to get the available fonts and determining the font families from there. It seems in your case that this function returns null while in our case the other function returns null....
We will try then to fall back to the other approach if one fails and update the Mac distribution hopefully today. Watch this topic as we will post here a notification when the new kit will be ready.

Thanks,
George
Dan
Posts: 309

Thu Apr 03, 2003 4:07 pm

I have changed the Mac OS X distribution, to contain a more robust Font scanning. Please download the kit again from: http://www.oxygenxml.com/InstData/MacOSX/oxygen.zip
Make sure you clear first your browser's cache.
jpkang
Posts: 11
Location: Princeton, NJ

update

Thu Apr 03, 2003 5:45 pm

I cleared Safari's cache, downloaded it, and tried it, but it refuses to recognize the license.key file, and keeps asking for registration info each time I launch... :(
Dan
Posts: 309

Thu Apr 03, 2003 7:12 pm

Looks like the program is not finding the license resource. You can try to copy the "license.key" into the "dicts" folder. Also copy the archive "license.zip" file in the same folder. If this still does not work I will send you a logging file, so we can detect what's wrong.
jpkang
Posts: 11
Location: Princeton, NJ

hm...

Thu Apr 03, 2003 10:20 pm

I think something must be wrong now with my Java install... oXygen 1.2.4, which was opening without problems yesterday, now will not start. I will reinstall Java 1.4.1 and see if that takes care of my issues.
jpkang
Posts: 11
Location: Princeton, NJ

It works now!

Fri Apr 04, 2003 2:05 am

I reinstalled Java 1.4.1, rebooted, and now oXygen 2.0 opens, albeit with the following error messages in my console.log. Speed seems fine (I'm running it on an 800MHz G4).

2003-04-03 17:57:44.509 JavaApplicationStub[609] Warning: Font LucidaSans-TypewriterBold claims fixed-pitch with 0 max advance!
2003-04-03 17:57:54.932 JavaApplicationStub[609] Warning: Font LucidaSans-TypewriterBold claims fixed-pitch with 0 max advance!
17:57:59,071 4 ERROR [ main ] ro.sync.util.FontChooser - Cannot find any fonts.
java.lang.NullPointerException
at ro.sync.ui.b.b1(Unknown Source)
at ro.sync.ui.b.b4(Unknown Source)
at ro.sync.ui.b.<init>(Unknown Source)
at ro.sync.ui.b.b2(Unknown Source)
at ro.sync.exml.b.c.for(Unknown Source)
at ro.sync.e.j.a(Unknown Source)
at ro.sync.exml.b.r.bn(Unknown Source)
at ro.sync.e.d.bo(Unknown Source)
at ro.sync.e.d.<init>(Unknown Source)
at ro.sync.exml.b.r.<init>(Unknown Source)
at ro.sync.exml.b.r.bq(Unknown Source)
at ro.sync.exml.MainFrame.<init>(Unknown Source)
at ro.sync.exml.MainFrame.<init>(Unknown Source)
at ro.sync.exml.Launcher.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at ro.sync.exml.Oxygen.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at apple.launcher.LaunchRunner.run(LaunchRunner.java:88)
at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
com.apple.macos.useScreenMenuBar has been deprecated. Please switch to apple.laf.useScreenMenuBar
jpkang
Posts: 11
Location: Princeton, NJ

Stability

Sat Apr 05, 2003 8:46 am

I think I may have spoken too soon. Though 2.0 opens, it crashes frequently, and is also quite slow doing search-and-replace operations (the Find dialog box still behaves rather inconsistently, if not as strangely as in 1.2.4). I'm trying to search English text and replace it with Hebrew entities... I'm finding it quicker to do this with BBEdit and then copy and paste it into oXygen. I think I'm going to have to wait for another release of 2.x before I can upgrade from 1.2.4.

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 1 guest