Custom DITA-OT PDF plugin transform fails with AH Formatter v7

matt_k
Posts: 4
Joined: Mon Aug 17, 2020 7:16 pm

Custom DITA-OT PDF plugin transform fails with AH Formatter v7

Post by matt_k » Tue Aug 18, 2020 4:52 pm

Hi there

I recently used a temporary license of AH Formatter v6 to test PDF output from Oxygen on my Mac, using our custom DITA-OT plugins, which was successful.

However, I have just installed a full license of AH Formatter v7 and output is failing using the same DITA-OT custom plugins. Here is an example of the error:
System ID: /Users/myname/Documents/Local_publishing/publication/publication_ditamap-bundle/publication.ditamap
Scenario: PDF Key Facts
Input file: /Users/myname/Documents/Local_publishing/publication/publication_ditamap-bundle/publication.ditamap
Engine name: DITA-OT
Severity: fatal
Description: Transformation failed. /Applications/Oxygen XML Editor/frameworks/dita/DITA-OT3.x/plugins/org.dita.pdf2.axf/build_axf.xml:179: Unable to locate AXF, set property axf.path or axf.cmd

System ID: /Applications/Oxygen XML Editor/frameworks/dita/DITA-OT3.x/plugins/org.dita.base/build.xml
Scenario: PDF Key Facts
Input file: /Users/myname/Documents/Local_publishing/publication/publication_ditamap-bundle/publication.ditamap
Engine name: DITA-OT
Severity: error
Description: The following error occurred while executing this line:
Start location: 29:0

System ID: /Applications/Oxygen XML Editor/frameworks/dita/DITA-OT3.x/plugins/org.dita.pdf2/build.xml
Scenario: PDF Key Facts
Input file: /Users/myname/Documents/Local_publishing/publication/publication_ditamap-bundle/publication.ditamap
Engine name: DITA-OT
Severity: error
Description: The following error occurred while executing this line:
Start location: 148:0

System ID: /Applications/Oxygen XML Editor/frameworks/dita/DITA-OT3.x/plugins/org.dita.pdf2.axf/build_axf.xml
Scenario: PDF Key Facts
Input file: /Users/myname/Documents/Local_publishing/publication/publication_ditamap-bundle/publication.ditamap
Engine name: DITA-OT
Severity: error
Description: Unable to locate AXF, set property axf.path or axf.cmd
Start location: 179:0
There are these two parameters in the scenario:

axf.cmd (Specifies the path to the Antenna House Formatter executable – which has been set in the Oxygen preferences)
axf.opt (Specifies the user configuration file for Antenna House Formatter – there is only a font config file in my AH Formatter folder, no user config)

Both are currently empty (as they were when I used v6).

Could anyone suggest what I have done wrong here, please.

Thanks

Matt

Radu
Posts: 7150
Joined: Fri Jul 09, 2004 5:18 pm

Re: Custom DITA-OT PDF plugin transform fails with AH Formatter v7

Post by Radu » Wed Aug 19, 2020 9:25 am

Hi Matt,

I double checked this on my side running on Mac OS, and this seems to work for me.
So on my side Antenna House got installed by default in "/usr/local/AHFormatterV70".
I went to the Oxygen Preferences->"XML / PDF Output / FO Processors" page, removed everything from the "External FO Processors" list and then used the special "Browse" button at the bottom of the page to browse for the Antenna House installation.
Once I did this, Oxygen added a new entry in the "External FO Processors" list. I pressed the "Edit" button on that entry and the command line for it was something like:

Code: Select all

/usr/local/AHFormatterV70/run.sh -d ${fo} -p ${ah_method} -o ${out} -extlevel 4
Then I saved my changes in the Preferences dialog, I edited the PDF transformation scenario and in the "FO processor" tab I selected "Antenna House". Oxygen presented a label under the combo box showing me where the Antenna House installation is located. Then I published to PDF and it produced the PDF with Antenna House.

If this will still not work for you maybe you can set the "axf.cmd" transformation parameter to a value like /usr/local/AHFormatterV70/run.sh or the equivalent value on your side.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

matt_k
Posts: 4
Joined: Mon Aug 17, 2020 7:16 pm

Re: Custom DITA-OT PDF plugin transform fails with AH Formatter v7

Post by matt_k » Wed Aug 19, 2020 11:49 am

Hi Radu

Thank you for your reply.

I followed your clear instructions and output is now working okay.

The problem was with the code under "External FO Processors". For some reason when I added AHFormatter 7 the other day, "run.sh" was showing as "run.sh66", I've got no idea how that happened.

Regards

Matt

Post Reply