Bug with conref push using conkeyref

rtimkovi
Posts: 6
Joined: Wed Dec 26, 2018 8:04 am

Bug with conref push using conkeyref

Post by rtimkovi » Sun Aug 18, 2019 2:23 am

I'm evaluating Content Fusion and ran into a bug with my content. It looks like it ignores a conref push using conkeyref. I get the proper output using "DITA Map PDF - based on HTML5 & CSS" in Oxygen Editor 21.1, but my pushed content is missing when viewed in Content Fusion. I don't know how to tell what version of Content Fusion I have. I'm running it on AWS using the AMI available in the US West (Oregon) Region.

These files illustrate the problem.

fusionbug.ditamap:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<?xml-model href="urn:oasis:names:tc:dita:rng:map.rng" schematypens="http://relaxng.org/ns/structure/1.0"?>
<map>
    <title>Fusion bug</title>
    <topichead  processing-role="resource-only">
        <topicmeta>
            <navtitle>Resource definitions</navtitle>
        </topicmeta>
        <keydef keys="conrefs" href="conrefs.dita"/>
    </topichead>
    <topicref keys="mytopic" href="topic1.dita"/>
</map>
conrefs.dita:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<?xml-model href="urn:oasis:names:tc:dita:rng:topic.rng" schematypens="http://relaxng.org/ns/structure/1.0"?>
<?xml-model href="urn:oasis:names:tc:dita:rng:topic.rng" schematypens="http://purl.oclc.org/dsdl/schematron"?>
<topic id="conrefs">
    <title>Conrefs</title>
    <body>
        <p conaction="mark" conkeyref="mytopic/first-p"/>
        <p conaction="pushafter">This paragraph gets inserted.</p>
    </body>
</topic>
topic1.dita:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<?xml-model href="urn:oasis:names:tc:dita:rng:topic.rng" schematypens="http://relaxng.org/ns/structure/1.0"?>
<?xml-model href="urn:oasis:names:tc:dita:rng:topic.rng" schematypens="http://purl.oclc.org/dsdl/schematron"?>
<topic id="topic1">
    <title>topic1</title>
    <body>
        <p id="first-p">This is my first paragraph.</p>
        <p>This is my last paragraph.</p>
    </body>
</topic>
I see the inserted paragraph in the topic when I publish locally, but with Content Fusion, I don't. Is this a known problem?

Rick

mihaela
Posts: 204
Joined: Wed May 20, 2009 2:40 pm

Re: Bug with conref push using conkeyref

Post by mihaela » Mon Aug 19, 2019 12:21 pm

Hi,

Indeed we do not present the expanded content for a conref push using conkeyref. We received similar requests so we have an issue registered in our internal issue tracker for this improvement. I added your vote for it.

I cannot provide a roadmap for it since we have not started to work or estimate its feasibility. We will update this thread if it will be implemented.

Best regards,
Mihaela
Mihaela Calotescu
http://www.oxygenxml.com

rtimkovi
Posts: 6
Joined: Wed Dec 26, 2018 8:04 am

Re: Bug with conref push using conkeyref

Post by rtimkovi » Tue Aug 20, 2019 2:26 am

Thanks for the fast reply, Mihaela. I'll restructure the content to avoid this issue.

Rick

Post Reply