Authoring new topics in DITAmaps Manager

user234
Posts: 8
Joined: Wed May 22, 2019 11:54 am

Authoring new topics in DITAmaps Manager

Post by user234 » Mon May 27, 2019 11:43 am

Hi there,

I have had some issues with my topics not being transferred or copied properly to the output file.

I realized a few things that I hope I can have clarified as to why this happened:

I created a bookmap.
I then selected the append child - reference - "*****.ditamap'
I noticed two things:
Those maps that I created NOT using the 'fast create topics' feature worked perfectly with not issue.
Those maps that I created topics THAT DID use the 'fast create topics' feature would not copy the the topics over into the output file.

This was peculiar as the Editor said my map was valid, and there were no error messages when I transformed the bookmap. The Topics simply did not exist in the output folder.
Any idea why this is? Am I using the 'Fast Create Topics' feature in a way I shouldn't? Is there a way to salvage all of the topics I created using 'Fast Create Topics', and not having to redo them all individually?


Thanks
Natalie.

Radu
Posts: 6503
Joined: Fri Jul 09, 2004 5:18 pm

Re: Authoring new topics in DITAmaps Manager

Post by Radu » Mon May 27, 2019 2:17 pm

Hi Natalie,

Is this the same problem as the one you reported here:

post53920.html#p53920

? I asked for various details there in order to help further.
If you thing our 'fast create topics' is to blame you can try to use our Tools->"Compare files" utility to compare XML documents created in both ways, see if you can spot a problem.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply