SharePoint Authentication

<oXygen/> general issues.
dmonkyking
Posts: 1
Joined: Fri May 24, 2019 7:06 pm

SharePoint Authentication

Post by dmonkyking » Fri May 24, 2019 7:16 pm

I'm trying to integrate our SharePoint site with Oxgyen Editor (v.19) through CMS. I have the SP server added, but we don't use a username and password (we use a Common Access Card (CAC) that I'm assuming uses LDAP for authentication, but this isn't my field of expertise). When we open our SharePoint site in Internet Explorer it never asks for our credentials, because it automatically authenticates it based on the logged in user. How would I go about authenticating the SP users and passwords for Oxygen? Or is that something I can't do on my end (I don't have admin access)?

adrian
Posts: 2535
Joined: Tue May 17, 2005 4:01 pm

Re: SharePoint Authentication

Post by adrian » Tue May 28, 2019 12:19 pm

Hello,
dmonkyking wrote:
Fri May 24, 2019 7:16 pm
When we open our SharePoint site in Internet Explorer it never asks for our credentials, because it automatically authenticates it based on the logged in user.
I believe you are using Single Sign On (SSO) on the SharePoint site. Currently (as of 21.1) Oxygen does not support SSO authentication for SharePoint. So, unfortunately, it's not possible for Oxygen to authenticate on SharePoint without a username and password. This means the SharePoint site has to allow user/password authentication (depends on the site configuration).

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Post Reply