Error transforming a topic with video objects to XHTML/HTML5

d_croft
Posts: 20
Joined: Fri Feb 20, 2015 10:25 am

Error transforming a topic with video objects to XHTML/HTML5

Post by d_croft » Wed Mar 13, 2019 4:38 pm

Hello,

I have a DITA topic with a few m4v videos embedded as objects, like so:

Code: Select all


<object data="attachments/videos/video.m4v"
outputclass="video"/>
This was done by using the Oxygen Insert media feature.

When I try to transform this topic into XHTML or HTML5, I get the following error message:

Code: Select all


[DOTJ013E][ERROR] Failed to parse the referenced file 'file:/home/docs/fi/user-guide/attachments/videos/video.m4v'.: An empty sequence is not allowed as the value of variable $dita
What could be the cause of this?

Radu
Posts: 6589
Joined: Fri Jul 09, 2004 5:18 pm

Re: Error transforming a topic with video objects to XHTML/HTML5

Post by Radu » Wed Mar 13, 2019 4:57 pm

Hi,

What version of Oxygen are you using? Are you using Oxygen's bundled publishing engine or your own DITA OT publishing engine?
Somehow in this case the publishing engine seems to want to parse the video as if it were a DITA topic. Do you refer to the video from some other topics as well? Maybe with an xref without the proper @format attribute set on it?
Can you reproduce the problem with a very small sample project (one map, one small topic, one video)?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

d_croft
Posts: 20
Joined: Fri Feb 20, 2015 10:25 am

Re: Error transforming a topic with video objects to XHTML/HTML5

Post by d_croft » Fri Mar 15, 2019 11:59 am

Hi,

I'm using Oxygen 20.1 and DITA-OT 3.2, so not the bundled OT version. There are no other references to this video, it's just used in that one topic.

Yes, that same error was produced with a small testing material with just one topic, video and map.

Radu
Posts: 6589
Joined: Fri Jul 09, 2004 5:18 pm

Re: Error transforming a topic with video objects to XHTML/HTML5

Post by Radu » Fri Mar 15, 2019 12:10 pm

Hi,

This is a bug in the DITA OT 3.x, it's listed here:

https://github.com/dita-ot/dita-ot/issues/2947

For the DITA OT 3.2.1 we bundled with Oxygen 21 we added a patch plugin called com.oxygenxml.dost.patches which fixes this specific problem and a couple of others.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

d_croft
Posts: 20
Joined: Fri Feb 20, 2015 10:25 am

Re: Error transforming a topic with video objects to XHTML/HTML5

Post by d_croft » Fri Mar 15, 2019 12:12 pm

Ok, great.

I also just found that issue, and someone suggested that removing the org.lwdita plugin would also help, and it did.

Post Reply