Webhelp creates wrong index links

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
Edwin
Posts: 21
Joined: Tue May 17, 2016 4:58 pm

Webhelp creates wrong index links

Post by Edwin » Thu Jun 21, 2018 12:54 pm

When I create webhelp using the standard oxygen webhelp function the hyperlinks created are wrong. How do I set the path to be used for the links?

My ditamap is stored in a different folder (en-US) from the topics in the subfolder topics.
The links created for the indexterms are rendered as:
../index.html#en-US/Topics/example.html

However the webhelp output does not contain the same folder structure, it just contains the topics folder. I need to remove the en-US phrase manually.

The creation of the toc is not bothered by this, these links are rendered perfectly:
../index.html#Topics/example.html

I've been trying to search where/how I can set the path for the indexterms but could not find it. A typical dita topic containing indexterms looks like this:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd" >
<topic id="topic_v1g_m5h_rw" xml:lang="en-US" rev="1.10.0" >
<title>User Preferences</title>
<shortdesc/>
<prolog>
<metadata>
<keywords>
<indexterm>Preferences<index-sort-as>Preferences</index-sort-as></indexterm>
<indexterm>Language settings<index-sort-as>Language settings</index-sort-as></indexterm>
<indexterm>Result list preferences<index-sort-as>Result list preferences</index-sort-as></indexterm>
<indexterm>Family settings<index-sort-as>Family settings</index-sort-as></indexterm>
<indexterm>Keyword occurrence<index-sort-as>Keyword occurrence</index-sort-as></indexterm>
<indexterm>Keyword legend<index-sort-as>Keyword legend</index-sort-as></indexterm>
<indexterm>Family<index-sort-as>Family</index-sort-as></indexterm>
<indexterm>Family member to display<index-sort-as>Family member to display</index-sort-as></indexterm>
<indexterm>Authority<index-sort-as>Authority</index-sort-as></indexterm>
<indexterm>User interface language<index-sort-as>User interface language</index-sort-as></indexterm>
<indexterm>Display language<index-sort-as>Display language</index-sort-as></indexterm>
<indexterm>Search language<index-sort-as>Search language</index-sort-as></indexterm>
</keywords>
</metadata>
</prolog>
I'm using Oxygen 17.1

Edwin
Posts: 21
Joined: Tue May 17, 2016 4:58 pm

Re: Webhelp creates wrong index links

Post by Edwin » Fri Jun 22, 2018 10:29 am

Found a solution today, use the parameter fix.external.refs.com.oxygenxml when creating output
all links are rendered perfectly...

:D

Radu
Posts: 6179
Joined: Fri Jul 09, 2004 5:18 pm

Re: Webhelp creates wrong index links

Post by Radu » Fri Jun 22, 2018 11:02 am

Hi,

Right, probably you had references to resources outside of the main DITA Map folder as it's explained here:

https://www.oxygenxml.com/doc/versions/ ... -refs.html

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

Post Reply