SVGs exported from draw.io do not display correctly in Oxygen XML Author 20

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
asher
Posts: 7
Joined: Tue May 08, 2018 7:53 pm

SVGs exported from draw.io do not display correctly in Oxygen XML Author 20

Post by asher » Thu May 17, 2018 7:50 pm

In Author mode, the text in SVGs exported from draw.io does not display correctly. However, in the webhelp output, the text does display correctly when viewed in Chrome or Firefox.

This is a common problem. Here is an excerpt from an article in draw.io Helpdesk:
We use something called foreign objects in SVG to allow complex, HTML labels on shapes. All modern browsers including Chrome, Firefox, Safari and Microsoft Edge support this (Internet Explorer 11 and earlier does not).
Link to Helpdesk article: https://desk.draw.io/support/solutions/ ... g-editors-

Radu
Posts: 6266
Joined: Fri Jul 09, 2004 5:18 pm

Re: SVGs exported from draw.io do not display correctly in Oxygen XML Author 20

Post by Radu » Fri May 18, 2018 9:47 am

Hi,

Oxygen uses the Apache Batik library to render SVGs presented in the Author editing mode so indeed what Oxygen renders when editing may sometimes differ from what a web browser shows depending on the differences between our engine and a web browser's SVG rendering engine.
If you want us to look into this further maybe you can contact us directly (support@oxygenxml.com) and provide a sample SVG for us to test.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

asher
Posts: 7
Joined: Tue May 08, 2018 7:53 pm

Re: SVGs exported from draw.io do not display correctly in Oxygen XML Author 20

Post by asher » Mon May 21, 2018 2:21 am

Thanks Radu. I will send you a sample.

Post Reply