Archive browser and combining marks

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
jardenblack26
Posts: 2

Archive browser and combining marks

Tue May 15, 2018 12:26 pm

I have a set of four Word documents. Three of the four open up just fine through the Archive Browser but the fourth grinds oXygen to a halt. It's faster for me to end the task, restart oXygen, and start from scratch. After several hours I was able to determine that U+0308 COMBINING DIARESIS was causing the problem in the fourth file, but this is puzzling, since I have that character numerous times in the other three Word files, which open up quite nicely. Has anyone run into this issue before?
Last edited by jardenblack26 on Sun May 27, 2018 8:22 am, edited 1 time in total.
adrian
Posts: 2442

Re: Archive browser and combining marks

Tue May 15, 2018 3:17 pm

Hi,

What version and build of Oxygen are you using (Help > About)?
If the Word document in question does not contain any confidential information, could you please submit it for analysis on our Technical support page?

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
adrian
Posts: 2442

Re: Archive browser and combining marks

Wed May 16, 2018 3:23 pm

Hi,

On second thought, I'm guessing you actually mean it grinds to a halt when you open it in the main editor.
Since you mentioned the U+0308 COMBINING DIAERESIS character, which usually triggers the bidirectional text support in the editor, please make sure you still have checked in Options > Preferences, Editor > Open/Save, the option "Disable special characters support for documents larger than ...". This option needs to be checked to avoid such performance problems, if the document that triggers the bidirectional text support is too large. At best you could set the size to 500000 or 800000, but do not clear the box.
If the problem persists, also check the "Prompt for each document" radio box option and when prompted to choose if you want to enable the special characters support, pick Disable.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 0 guests