Syntax highlight doesn't work with xquery files

Having trouble installing <oXygen/>? Got a bug to report? Post it all here.
brilliantcontract
Posts: 5

Syntax highlight doesn't work with xquery files

Thu Mar 08, 2018 9:31 pm

I got a problem, syntax highlight doesn't work with xquery files.

I worked with XML Editor 17.1 and I didn't have any problems with this version.

I installed XML Editor 18.1, but there no syntax highlight for xquery.

It's cause for working in 17.1

Screenshot:
https://drive.google.com/file/d/1RcwJhE ... sp=sharing

If anyone has experience with this problem, please share how you coped with it.
Radu
Posts: 5872

Re: Syntax highlight doesn't work with xquery files

Fri Mar 09, 2018 10:36 am

Hi,

Unfortunately the image you placed on google drive is not publicly available so I could not see it.
If you go to the Oxygen Preferences->"File Types" page and use the Restore Defaults button, save the preferences, then try again to open an XQuery document does it work better?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Radu
Posts: 5872

Re: Syntax highlight doesn't work with xquery files

Thu Mar 15, 2018 9:46 am

Hi,

Does pressing the "Restore defaults" button in the Editor / Syntax Highlight Preferences page and then clicking "Apply" or "OK" help?
If not, have you added a custom theme in the Appearance Preferences page? The default theme for Windows should be "Light".
Otherwise maybe using the main menu Options->Reset Global Options action to reset your preferences to the default ones might help.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
brilliantcontract
Posts: 5

Re: Syntax highlight doesn't work with xquery files

Fri Mar 23, 2018 2:23 am

Thank you for answer.
Let me give more information.
I'm Linux user, I use Ubuntu 16.04 TLS (fresh installed stable version)

I have installed oXygen 17.1 - it works great including xQuery syntax highlight.
Then I installed oXygen 18.1 - it also works great, but without xQuery syntax highlight.

Syntax for all other file types supports well.

I have fixed permissions to see the image file https://drive.google.com/file/d/1RcwJhE ... h_SJ_/view
brilliantcontract
Posts: 5

Re: Syntax highlight doesn't work with xquery files

Fri Mar 23, 2018 2:26 am

Sadly but Reset Global Options and the "Restore defaults" button didn't help me.
adrian
Posts: 2461

Re: Syntax highlight doesn't work with xquery files

Fri Mar 23, 2018 10:49 am

Hi,

If resetting the options did not fix the problem, the problem is with the installation.
Did you install v18.1 in a folder with an existing Oxygen installation?
It could be that you have a library conflict from a previous installation.

Please try uninstalling v18.1 and reinstalling it in a fresh folder.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
brilliantcontract
Posts: 5

Re: Syntax highlight doesn't work with xquery files

Sun Apr 08, 2018 3:39 am

Thank you for helping, indeed the problem was in the broken installation.
I had removed oxygen editor after I installed it again. Now oxygen editor works well.

Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 1 guest