Problem with XML code for dita files translation

<oXygen/> general issues.
jmanier
Posts: 35
Joined: Thu Jun 08, 2017 3:41 pm

Problem with XML code for dita files translation

Post by jmanier » Tue Sep 26, 2017 5:57 pm

Hi,

I have a problem with my XML code for translation.

Actually, i want to translate my dita files which is possible and working but my problem is that textual content is :
<p>The color of the sky
is blue. The sun is
shining.</p>

It's ok for everything, for the different scenarios of transformation, etc. but when i'm translating my content with a translation tool (supporting dita files), i got the feeling that the sentences are separated according random separations on XML files (i'm writing from author)... In my example (not a real one), "The color of the sky" wont be associated to "is blue" during the translation operation and that's a problem.

Is there an efficient solution to fix this problem please ?

Thank you in advance.
Regards,

Jeremy

Radu
Posts: 6211
Joined: Fri Jul 09, 2004 5:18 pm

Re: Problem with XML code for dita files translation

Post by Radu » Wed Sep 27, 2017 8:07 am

Hi Jeremy,

This might mean that the translating tool interprets the XML file line by line which is incorrect.
So maybe you should talk to them about this problem.
Also if you want you can register on the Yahoo Groups DITA Users List and ask there for similar stories, maybe there are DITA users there who had the same problem and found various workarounds (besides changing the translation tool).

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com

jmanier
Posts: 35
Joined: Thu Jun 08, 2017 3:41 pm

Re: Problem with XML code for dita files translation

Post by jmanier » Wed Sep 27, 2017 10:45 am

Hi,

Thank you for your answer. I try the Yahoo groups DITA then.

Regards,

Jeremy

Post Reply