Display placeholer for empty table cells

<oXygen/> general issues.
Patrik
Posts: 228
Location: Hamburg/Germany

Display placeholer for empty table cells

Tue Jul 04, 2017 8:24 am

Hi,

In all my empty table cells there is no placeholder displayed - even when I explicitly set

Code: Select all

-oxy-show-placeholder:always;
by css.

I know I could define a css rule to manually display some content for empty elements. But I'mstill wondering why this seems not to work by default as it does for other elements!?

Thanks and regards,
Patrik
Radu
Posts: 5757

Re: Display placeholer for empty table cells

Tue Jul 04, 2017 9:50 am

Hi Patrik,

Indeed we are quite reluctant to display the place holder text on the cell (because we considered that it looks ugly) although when you force from the CSS the place holder our code should obey your CSS property. I will add an internal issue for this.
In the meantime you can do something like this from the CSS:

Code: Select all

-oxy-placeholder-content:oxy_name();


Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Patrik
Posts: 228
Location: Hamburg/Germany

Re: Display placeholer for empty table cells

Tue Jul 04, 2017 12:52 pm

Hi Radu,

I agree, that for standard tables (e.g. in DITA) the placeholder is better to be hidden - especially when you have plenty of emptyy cells.

But when using custom XML (or specialized DITA) the placeholder is very useful - especially when you have a schematron rule complaining about empty elements, because without the paceholder there is no content to have the red underline.

However, using -oxy-placeholder-content works fine for me. So I consider this issue to be solved.

Thanks and regards,
Patrik

Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 3 guests