Search not working with local transform

ann.jensen
Posts: 214

Search not working with local transform

Fri May 05, 2017 11:02 am

Hi,
I may be losing it :-|....but should Search work when using the output from a local WebHelp transform done in Oxygen XML Author?
Mine is unresponsive when I interact with it.
Any advice appreciated,
Regards,
Ann
bogdan_cercelaru
Posts: 202

Re: Search not working with local transform

Fri May 05, 2017 4:44 pm

Hello,

What version and build number of Oxygen are you using to generate the WebHelp output? Which transformation scenario are you using: the DITA Map WebHelp Classic or DITA Map WebHelp Responsive?
The search function should work even if you are accessing the WebHelp output locally in both versions of WebHelp: responsive or classic.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
ann.jensen
Posts: 214

Re: Search not working with local transform

Fri May 05, 2017 4:48 pm

Hi Bogdan,

I am using Oxygen XML Author v 19.0 and transforming using WebHelp Responsive plugin.
I launch the output from C:\<path to my files>\out\webhelp-responsive\index.html. When I enter a keyword into the search box and click Search I am brought to file:///C:\<path to my files>/out/webhelp-responsive/search.html?searchQuery=bla but there are no results and I don't understand why.
Thanks,
Ann
bogdan_cercelaru
Posts: 202

Re: Search not working with local transform

Fri May 05, 2017 5:04 pm

Hello,

I've just tried with Oxygen v19.0, build 2017033118 and I cannot reproduce this behavior.
Using the our flowers.ditamap sample, I've applied the built-in DITA Map WebHelp Responsive transformation scenario. After the transformation successfully ended, the browser open with the generated WebHelp. I enter the string "iris" in the search input and press the search button. The browser now redirects me to the "file:///.../samples/dita/flowers/out/webhelp-responsive/search.html?searchQuery=iris" and the page display the message "5 document(s) found for iris" and the found pages.
I've tested with the following browsers: Google Chrome, Firefox, IE11 and Microsoft Edge.
Are you using the built-in transformation scenario or a custom one? Please try with the built-in transformation scenario and let us know if it work.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
ann.jensen
Posts: 214

Re: Search not working with local transform

Fri May 05, 2017 5:45 pm

Hi Bogdan,
Yes it does work as expected with the built-in DITA Map WebHelp Responsive transformation scenario :-|
My transformation scenario is a customized version of the built-in DITA Map WebHelp Responsive transformation scenario.
Something has changed since I moved to Oxygen 19.0 as I am sure it was working fine before then.
Have you any ideas where I should start my investigations to trouble-shoot this?
Thanks in advance,
Ann
bogdan_cercelaru
Posts: 202

Re: Search not working with local transform

Wed May 10, 2017 12:33 pm

Hello,

Please transform our "flowers.ditamap" sample using your customized DITA-OT transformation scenario and send us the ZIP containing the generated output at support@oxygenxml.com.

Regards,
Bogdan
Bogdan Cercelaru
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
ann.jensen
Posts: 214

Re: Search not working with local transform

Mon May 15, 2017 10:58 am

Hi,
I have emailed on this information.
It is definitely an issue with my project and Oxygen WebHelp 19.0 as I see it happening after building on our upgraded server now also.
Any advice appreciated.
Regards,
Ann

Return to “DITA (Editing and Publishing DITA Content)”

Who is online

Users browsing this forum: No registered users and 1 guest