oxy_audio error in Author page

Post here questions and problems related to oXygen frameworks/document types.
Johann
Posts: 59

oxy_audio error in Author page

Thu Apr 06, 2017 3:45 pm

Hi everyone,

I'm using the 18.1.0.0 SDK version and when I try to use :

Code: Select all

multimedia {
content: oxy_audio(href, url(../test.MP3), width, 400px);
}


I get this error :

Code: Select all

java.lang.NoClassDefFoundError: ro/sync/jfx/JFXException
   at ro.sync.ecss.component.editor.c.e.c(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.component.editor.c.b.ed(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.component.editor.c.b.id(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.x.qe(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.x.<init>(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.jb.y(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.eb.li(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.eb.<init>(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.hm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.em(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.am(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.fm(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.f.li(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.i.sb.li(Unknown Source) ~[oxygen-18.1.0.0.jar:na]
   at ro.sync.ecss.component.o.relayout(Unknown Source) ~[oxygen-18.1.0.0.jar:na]...


Any idea about this issue ?

Thanks,

Johann
Radu
Posts: 5088

Re: oxy_audio error in Author page

Thu Apr 06, 2017 4:55 pm

Hi Johann,

You are missing a Java library called oxygen-jfx-components.jar. I think you could pick it up from a standalone Oxygen XML Editor installation (from the "lib" folder). I will also discuss with my colleague who knows more about how the SDK was mavenized, see if we exposed this library via Maven or not.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Radu
Posts: 5088

Re: oxy_audio error in Author page

Fri Apr 07, 2017 9:26 am

Hi,

It seems that indeed we did not expose this extra library via Maven so right now you will have to manually add it as a dependency. I added an internal issue to also provide this library via Maven.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
Johann
Posts: 59

Re: oxy_audio error in Author page

Fri Apr 07, 2017 9:37 am

Hi Radu,

I manually added the dependency and it works.

Thank you,

Johann
Johann
Posts: 59

Re: oxy_audio error in Author page

Fri Apr 07, 2017 11:02 am

It works but I don't know if I have something wrong in my environment because the audio player is truncated both in the Oxygen XML software and in the Oxygen component (18.1 version).

This is what I see when opening C:\Program Files\Oxygen XML Editor 18\samples\form -controls\about\form-controls.xml :

Image

Any idea ?

Thanks,

Johann
alex_jitianu
Posts: 600

Re: oxy_audio error in Author page

Mon Apr 10, 2017 2:39 pm

Hi,

Do you happen to have a retina/ HiDpi screen?
I will send you an email with a modified version of oxygen-jfx-components.jar that contains a possible fix to this issue. You can replace the exisitng one inside {oxygenInstallDir}/lib and test again.

Best regards,
Alex
Johann
Posts: 59

Re: oxy_audio error in Author page

Wed Apr 12, 2017 11:05 am

Hello Alex,

I do not have a specific screen... I tried to replace the jar file by the one you sent by email but it does not change anything.
Am I the only one to have this behaviour ?

Johann
alex_jitianu
Posts: 600

Re: oxy_audio error in Author page

Wed Apr 12, 2017 12:02 pm

Hi Johann,

We tested on multiple stations and operating systems but we didn't reproduce this behavior. You are also the only one that reported this situation so far. Can you test an Oxygen version 19 and see if the same behavior happens when opening samples\form -controls\about\form-controls.xml? Perhaps we've solved it without even knowing...

Best regards,
Alex
Johann
Posts: 59

Re: oxy_audio error in Author page

Fri Apr 14, 2017 4:21 pm

Hi Alex,

I just tried in Oxygen version 19 and I get the same error when I open samples\form -controls\about\form-controls.xml...

Johann
alex_jitianu
Posts: 600

Re: oxy_audio error in Author page

Tue Apr 18, 2017 11:38 am

Hi Johann,

Do you have a custom DPI (Dots per Inch) size setting? Perhaps it will also help if you send us more information about your system. The fastest way to do that is to go inside Oxygen to Help->Report problem... and just send us the report.

Best regards,
Alex

Return to “SDK-API, Frameworks - Document Types”

Who is online

Users browsing this forum: No registered users and 0 guests