Content completion not working when Schema Associated

<oXygen/> general issues.
iljackb
Posts: 4

Content completion not working when Schema Associated

Mon Jul 04, 2016 12:26 pm

Hi I am trying to associate a RNG schema to a TEI document in which I need to use an element/attribute/value combination which references xml:id values of elements to be annotated.

Because the document is big this needs to make use of the content completion in which when you enter <interp inst="#"> - Oxygen automatically pops up the list of xml:id values in the document to select from.

However, when I create a RNG schema (using the 'Generate Schema' - I've tried compact and regular) Oxygen no longer produces the pop-up with the id's.

Why would this be and is there a way I can fix this?

Thanks very much in advance!
Radu
Posts: 5872

Re: Content completion not working when Schema Associated

Mon Jul 04, 2016 1:30 pm

Hi,

I do not understand why you are not using TEI Roma to build the custom RNG schema:

http://www.tei-c.org/Roma/

What schema are you converting to Relax NG using our tool?

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
iljackb
Posts: 4

Re: Content completion not working when Schema Associated

Tue Jul 05, 2016 12:17 pm

Radu wrote:I do not understand why you are not using TEI Roma to build the custom RNG schema:


There had been a problem with the Roma site but it is now fixed, I created the RNC from there and it works

Thanks

Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 1 guest