Performance: Lots of temp imageio requests

Are you missing a feature? Request it's implementation here.
sanGeoff
Posts: 42

Performance: Lots of temp imageio requests

Wed Dec 23, 2015 2:32 am

While trying to optimize our oXygen plug-ins and customization, I noticed a many temp calls by oXygen.

It seems there are many disk calls creating and deleting some kind of temporary image files.
%AppData%\Local\Temp\imageio######.tmp
(~25k calls on start-up taking 3.5 seconds, 7k on open document taking ~2 seconds)

Seems like an awful lot of IO overhead for temp images that are created and immediately deleted.

Just thought I might point it out as something to look into.
Might get some considerable performance/responsiveness improvement.
Could try to use memory only or have an image/icon resource cache.

Or is there some underlying reason it must use the file system and continuously reprocess 100's of images?

Thanks,
mihaela
Posts: 189

Re: Performance: Lots of temp imageio requests

Wed Dec 23, 2015 10:21 am

Hi,

Thank you for reporting this. We will analyze the temporary image files creation to see if this is indeed a performance issue.
We will notify you when we will have a conclusion.

Can you please tell us the type of the images you are using?

Best regards,
Mihaela.
Mihaela Calotescu
http://www.oxygenxml.com
sanGeoff
Posts: 42

Re: Performance: Lots of temp imageio requests

Wed Dec 23, 2015 10:20 pm

Hi, thanks again for the quick reply.

The temporary images occur when opening a completely empty DITA Topic in Author view.
Its really just a minor thing that might be able to be improved.
The temporary images appear to toolbar and menu icons.

That's kind of why I just posted here under feature request.
It takes about 4 seconds for a empty topic to open and 5 seconds to checkout and reopen.
I figured with 2 seconds possibly being spent doing icon image IO,
there might be a way <oXygen/> could cut load time of small DITA topics in half.

There's probably a reason it reprocesses the icons to enable as disable them or something.
If it where me, I would try and set-up an Icon memory array or something that caches them the first time.

Thanks again, happy holidays and happy new year.

Forgot to mention in my original post:
Win 7 64 bit, <oXygen/> XML Author 17.1.0 Standalone, build 2015111718
Dan
Posts: 304

Re: Performance: Lots of temp imageio requests

Thu Dec 24, 2015 12:13 pm

Hi,

We reproduced the problem and we fixed it. The fix was to disable the disk cache used by the ImageIO library.

From our tests the performance improvement is between 5% and 10%.

Thank you!
Dan

PS:To determine the file activity we used logging and Java profiling, but I would like to find out what tool have you used for monitoring the file activity.
sanGeoff
Posts: 42

Re: Performance: Lots of temp imageio requests

Thu Dec 24, 2015 8:28 pm

I use Process Monitor to capture system events.
https://technet.microsoft.com/en-us/sys ... nitor.aspx

Exported it to a spreadsheet, filtered by imageio, and summed the duration column.
I suspect we may see a larger improvement because of anti virus, encryption, and stuff.
That's a pretty decent improvement for opening small DITA topics with a small change as long as nothings adversely affected.

Thanks again for the super fast response.

Return to “Feature Request”

Who is online

Users browsing this forum: No registered users and 0 guests