updating saxon, dtds and xsl that are included with install?

<oXygen/> general issues.
elnino
Posts: 4

updating saxon, dtds and xsl that are included with install?

Thu Aug 18, 2005 6:05 pm

Hello, I'm a new user of oxygen, and I'm really excited about using this tool!

I noticed right away, that the versions of saxon and docbook, and docbook xsl are different versions than we currently use internally.

Are there any issues that I should know of, if I choose to update the dtds and docbook xsls that were autoamtically installed with oxygen? I'm looking to update the C:\Program Files\Oxygen 6.1\frameworks\docbook files.

For Saxon, Is it just a matter of replacing the jar file? or is there a way to configure oxygen to use both? Do I need to update the resolver.jar as well?

Thanks!

LN
george
Site Admin
Posts: 2100

Fri Aug 19, 2005 9:47 am

Hi,

Oxygen ships 3 versions of the DocBook DTD, and they are resolved though the catalog file, see frameworks/docbook/catalog.xml. If you want another version you can just add it and add an entry in the catalog to handle that.

You can replace frameworks/docbook/xsl with your desired XSL version.

Oxygen includes Saxon 6.5.4. If you want Saxon 6.5.3 just replace the saxon.jar from the lib folder with saxon.jar from Saxon 6.5.3. Saxon 6.5.4 adds a few fixes to Saxon 6.5.3 and it is recommended to move to that. All you can do if you want to use both is to configure one as an external tool.

Best Regards,
George

Return to “Other Issues”

Who is online

Users browsing this forum: No registered users and 1 guest